Solved

Corsair Force 3 90GB SSD, seen by OS but not usable...

I've had this SSD for a few months, but didn't really use it (was dreading reinstalls, had a Java IDE on it). I have been loading OS and SW:TOR off of my WD Caviar Blue 500GB (SATA 6Gb/s).

Had a power outage yesterday (high winds knocked down a tree into the lines, right in the middle of PVP too...). Everything in the PC worked fine today, except SW:TOR would show "SWTOR Launcher" in Task Manager, so after trying the usual fixes I decided to try a fresh install. Custom install blah blah blah... SSD (drive D) isn't on the list of drives. Double click "Computer"; "Hard Drives - 1". Start to panic a little. Go into Device Manager and it registers! So I right click and Properties and it says the device is running properly, driver is up to date, etc.

Overview:
SSD Not shown in "Computer"
SSD is shown in BIOS and in Windows Device Manager
Cannot install files onto SSD, or view files already on SSD
OS: Windows 7 Pro 64-Bit
Mobo: BIOSTAR TA990FXE
HDD: Western Digital Caviar Blue 500GB SATA 6Gb/s
SSD: Corsair Force 3 90GB SSD SATA 3

Any help is greatly appreciated.

Thanks in advance!
manicmike
5 answers Last reply Best Answer
More about corsair force 90gb usable
  1. Best answer
    If you...

    Right Click Computer > Manage > Disk Management.

    Does it show up there? If so, what does it say?

    Does it show up in the BIOS?
  2. Not sure what happened to it, but it said "Unallocated". Reformatting it as I type, thankfully nothing important was on it. Thanks for the help, I totally forgot about Disk Manager

    lol@self
  3. Best answer selected by manicmike.
  4. No problem, glad it worked out!
  5. You may also want to secure erase the SSD if you don't already have important data back on it.
Ask a new question

Read More

SSD Western Digital Storage