Sign in with
Sign up | Sign in
Your question

Onboard ethernet port randomly shuts off

Last response: in Motherboards
Share
December 29, 2010 8:24:56 PM

Hello,

What would cause my Asus M4A77D onboard ethernet port to randomly shut down after several weeks of use? I originally bought the system as a Ubuntu box the first of September and it went back to the shop for the second time today. I get no answers from the shop tech as to why this is happening and then they have my box for a week each time I take it in.
a b V Motherboard
December 29, 2010 9:13:36 PM

If the port randomly quits working, it could be either a hardware issue (defective ethernet controller) or a problem with the OS's stack. I'd try a USB or other add-on ethernet controller and see if the problem goes away with the new card. If it *does* go away, i'd start looking at a possible hardware issue. Why it takes your "shop" weeks at a time to diagnose this is beyond me. Maybe an hour, tops.
m
0
l
December 29, 2010 10:36:14 PM

mavroxur said:
If the port randomly quits working, it could be either a hardware issue (defective ethernet controller) or a problem with the OS's stack. I'd try a USB or other add-on ethernet controller and see if the problem goes away with the new card. If it *does* go away, i'd start looking at a possible hardware issue. Why it takes your "shop" weeks at a time to diagnose this is beyond me. Maybe an hour, tops.



Thank you, mavroxur, your analysis makes sense now that I hear it. As to why it takes them a week is beyond me also. I'll give them the benefit of the doubt, the techs may be busy with other repairs, mine just waiting its turn in line. But my machine has always been in their shop at least a week each time I take one box or another to them for the last six-seven years.

Thank you again for your input and analysis.
m
0
l
!