news://news.* protocol

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

Hello,

How do I get it so that when I click on a news://news.* link in a
program that is aware of my system settings (like my web-browser), that
windows will open my default news client. I currently use FireFox & IE6
for browsing, both will open OE when clicking on a news://* link,
whereas I wish for ThunderBird (Mozilla) to be the default. I assume
that I will have to change something on the File Types tab, in Folder
Options Control Panel. I also assume that I'll have to change the
"URL:News Protocol" and the "URL:NNTP Protocol" selections, but don't
know what to do from there. I don't need help with my 3rd party
application (Thunderbird), though. Thanks for the help. :)

-matson
8 answers Last reply
More about news news protocol
  1. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    Open Internet Explorer
    Click Tools, Internet Options, Programs tab
    Select the preferred program as your default news reader (Newsgroups)

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "David Matson" <david-matson@comcast.net> wrote in message news:uVKvkCi7EHA.3336@TK2MSFTNGP11.phx.gbl...
    Hello,

    How do I get it so that when I click on a news://news.* link in a
    program that is aware of my system settings (like my web-browser), that
    windows will open my default news client. I currently use FireFox & IE6
    for browsing, both will open OE when clicking on a news://* link,
    whereas I wish for ThunderBird (Mozilla) to be the default. I assume
    that I will have to change something on the File Types tab, in Folder
    Options Control Panel. I also assume that I'll have to change the
    "URL:News Protocol" and the "URL:NNTP Protocol" selections, but don't
    know what to do from there. I don't need help with my 3rd party
    application (Thunderbird), though. Thanks for the help. :)

    -matson
  2. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    thank you, Ramesh. I should of mentioned that I've done that already.
    It is set to my preferred news program (Thunderbird).

    -matson


    Ramesh [MVP] wrote:
    > Open Internet Explorer
    > Click Tools, Internet Options, Programs tab
    > Select the preferred program as your default news reader (Newsgroups)
    >
  3. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    Hi David,

    You may try this question here:
    http://forums.mozillazine.org/

    Enquire about the news: protocol / command settings for Thunderbird.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "David Matson" <david-matson@comcast.net> wrote in message news:ebaL2Vj7EHA.2192@TK2MSFTNGP14.phx.gbl...
    thank you, Ramesh. I should of mentioned that I've done that already.
    It is set to my preferred news program (Thunderbird).

    -matson


    Ramesh [MVP] wrote:
    > Open Internet Explorer
    > Click Tools, Internet Options, Programs tab
    > Select the preferred program as your default news reader (Newsgroups)
    >
  4. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    thank you. I am currently trying this in both a microsoft and in the
    mozilla forums. since it works fine for other users of Thunderbird
    (Mozilla) on WinXP, it seems to be a problem with my windows settings...
    thus I am asking in this microsoft forum how to set a news protocol
    handler. I notice that in Folder Options | File Types, that there is no
    "(None) URL:News Protocol", and that there does not seem to be an
    implementation to create a new one using the "New" button at that
    screen. I do not need help with the 3rd party application; I just need
    generic help on how to use my WinXP system to fix this system problem.
    Even by setting the default news client (internet options | Programs
    tab) to OE, links (in IE or Thunderbird) are not opened in OE... So this
    is NOT a Thunderbird problem. Using SysInternals' RegMon, I can see
    that there is a registry entry for mailto:// links when clicked on, but
    that there isn't for news:// links. Again, thank you for your support.
    If you can post what I should do to set the News Protocol handler (and
    not just the default client), I'll do my best to follow them. I should
    be able to follow them. I know that this was a little long, but I felt
    I needed to clarify.

    -david

    Ramesh [MVP] wrote:
    > Hi David,
    >
    > You may try this question here:
    > http://forums.mozillazine.org/
    >
    > Enquire about the news: protocol / command settings for Thunderbird.
    >
  5. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    ok, i typed in "regsvr32 /i shdocvw.dll" in start|run.. got error
    (exclamation):

    DllInstall in shdocvw.dll failed.
    Return code was: 0x80070005

    good news: i tried your reg key export and it works great! now that I
    have that, I can choose either OE or my other program to be the default
    with no problems.

    as a side note, I thought that shdocvw.dll handled folder and error
    views, such as the temp internet files system folder, the ie splash
    screen, the history system folder, the run prompt, help & support
    screen, etc... so two questions, please:
    1) why register shdocvw.dll?
    2) why did it fail? (and of course what should i do about it?)

    Thanks a million for getting the news protocol handler back on my XP.

    -david matson

    ps: oops... i forgot to do a runas command (or login as admin)... so
    that 0x80070005 was probably an access denied (currently logged in as a
    power user). sorry!


    Ramesh [MVP] wrote:
    > David,
    >
    > The reason why I redirected to Mozilla support is that they should be knowing the command-line parameters for Thunderbird (if any)
    >
    > Example: Outlook Express uses this command-line for news:
    > "C:\Program Files\Outlook Express\msimn.exe" /newsurl:"%1"
    >
    >
    > Now, because you're telling that there is no "URL : News Protocol" in the File types dialog:
    >
    > 1. Type "regsvr32 /i shdocvw.dll" in Start/Run. This create the default URL:News Protocol framework. Then select TBird from IE Options
    >
    > -or-
    >
    > 2. From a working XP system, export the following registry key:
    > HKEY_CLASSES_ROOT\news
    >
    > Then, import the REG file to your system.
    >
    > -or-
    >
    > 3. Apply the REG file which I've attached here with. This creates the URL: News Protocol entry, but sets OE as the default news reader. You can change it to Thunderbird using IE Options again.
    >
    > <Attached : news.reg>
    >
    >
    > If this helped, post back which of the above helped!
    >
  6. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    Hi David,

    Try registering the shdocvw.dll from from Administrator login. BTW, this DLL is very vital, similar to the shell32.dll. In addition to the features that you stated, this rebuilds the file association/protocol settings for internet explorer based file types. One of which that is fixed is the news protocol handler.

    HTH

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "David Matson" <david-matson@comcast.net> wrote in message news:uP5ZEQo7EHA.2032@tk2msftngp13.phx.gbl...
    ok, i typed in "regsvr32 /i shdocvw.dll" in start|run.. got error
    (exclamation):

    DllInstall in shdocvw.dll failed.
    Return code was: 0x80070005

    good news: i tried your reg key export and it works great! now that I
    have that, I can choose either OE or my other program to be the default
    with no problems.

    as a side note, I thought that shdocvw.dll handled folder and error
    views, such as the temp internet files system folder, the ie splash
    screen, the history system folder, the run prompt, help & support
    screen, etc... so two questions, please:
    1) why register shdocvw.dll?
    2) why did it fail? (and of course what should i do about it?)

    Thanks a million for getting the news protocol handler back on my XP.

    -david matson

    ps: oops... i forgot to do a runas command (or login as admin)... so
    that 0x80070005 was probably an access denied (currently logged in as a
    power user). sorry!
  7. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    i'll definitely remember (i'll save this) that. thx!

    -david


    Ramesh [MVP] wrote:
    > Hi David,
    >
    > Try registering the shdocvw.dll from from Administrator login. BTW, this DLL is very vital, similar to the shell32.dll. In addition to the features that you stated, this rebuilds the file association/protocol settings for internet explorer based file types. One of which that is fixed is the news protocol handler.
    >
    > HTH
    >
  8. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    You're welcome David.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "David Matson" <david-matson@comcast.net> wrote in message news:OxhIZso7EHA.208@TK2MSFTNGP12.phx.gbl...
    i'll definitely remember (i'll save this) that. thx!

    -david


    Ramesh [MVP] wrote:
    > Hi David,
    >
    > Try registering the shdocvw.dll from from Administrator login. BTW, this DLL is very vital, similar to the shell32.dll. In addition to the features that you stated, this rebuilds the file association/protocol settings for internet explorer based file types. One of which that is fixed is the news protocol handler.
    >
    > HTH
    >
Ask a new question

Read More

Configuration Windows XP