Sign in with
Sign up | Sign in
Your question

Asus M4A88TD-v Evo usb3 not reading anything usb. Please help!

Last response: in Motherboards
Share
December 31, 2010 9:09:04 PM

I recently decided to rearange my cables in my case so it looked cleaner, nicer, and had a better airflow. After i plugged everything in it decieded to not read anything usb. the only thing that it can read is a keyboard. i am having troubles doing almost anything on this computer because i cant use a mouse. it also cant read a ps2 port mouse. but it can read a ps2 keyboard. My Motherboard is a Asus M4A88TD-V Evo usb 3.0. i am runnning windows 7 x64. I have tried to run the W7 install disk and it just wont read. If anyone has any solutions that would be great.
a b V Motherboard
December 31, 2010 9:49:20 PM

Did you install the USB and other drivers off the DVD that came with the MB?
m
0
l
December 31, 2010 10:41:37 PM

Yes i reinstalled them after it stopped working. I tried a USB keyboard and it reads that and it read my old ps2 mouse... so i just see that as strange that the usb keyboard is being read but not the mouse.

one more thing is that the mouse's lights turn on when i plug it in for about 2 seconds and then the lights go out. ive downloaded the drivers for my Razer Lachaises or w/e way its spelled so im just confuzed on why it read the keyboard and not the mouse
m
0
l
!