Sign in with
Sign up | Sign in
Your question

New i7 860 and sabertooth 55i Won't post

Last response: in Systems
Share
April 21, 2010 3:29:19 AM

Step two: The Opening
Brand new build thats never worked, and I can't get it to post


Step four: The Full Story:
Got all the parts and put them in the case, and I can't get any video on screen, don't get any beeps for errors but I also don't get the beep letting me know that the post has worked

Step five: The specs
List each one of the parts in your computer. This must be a full list. If some parts are from an older build, this might be important.
CPU- Intel i7 860
Motherboard- Asus Sabertooth 55i
RAM- Patriot PGV34G2000ELK 4GB (2x2GB) DDR3
CPU cooler- Thermaltake SpinQ VT CPU Cooler
Video Card- XFX ATI Radeon HD5850 BLACK EDITION
Power Supply- Antec TruePower Quattro 850W

Don't think these make a difference to my issue?
Hard drive(s)
Operating System
Case (for cooling issues)
ANY other parts. If you have an ipod plugged in, we want to know.

Step six:
List all the steps you have taken to resolve this yourself. Number them.
1. Using 1 RAM stick
2. Switching sticks
3. Testing on bench
4. Changing PCIe slots for video card
5. Using the memok button, which is supposed to make all memory compatible
6. Removed video card, still no beeps
7. Removed RAM, so only CPU and HSF left, and getting a long beep and 2 short beeps... Which is apparently a video problem?
8. Removed RAM, so CPU, HSF and video card are left, and still get long beep and 2 short beeps

So I only get beeps when I have no RAM installed, but the beeps I get are for the video card, even if the video card is in... Would this be faulty RAM, a faulty motherboard or a faulty video card? Or is there anything else I can try


Thanks
Brodie
!