M2n sli deluxe compatibility radeon

Hello,

I bought today Sapphire radeon H5 5850 Toxic.I try to use it but my motherborad fail to boot.Motherboard is M2n SLI Deluxe and previous card was nvidia 7600GT.I„m desperate so please help.Thanks
5 answers Last reply
More about deluxe compatibility radeon
  1. Did you uninstall the Nvidia drivers?
    Can your power supply handle the HD5850?
  2. Of couse I„ve uninstalled nvidia drivers first.I bought the power supply especially for this card (Enermax Liberty II 620).
  3. I`ve read the Asus forum and it seems that is an issue regarding ati new series and my motherboard.This is very frustrating cause there are a lot of users who experience this issue and no reply from ASUS support.

    Soon I plan to buy another motherboard cause I want to buy I7 and I`m sure that will not be an ASUS cause I don`t want to buy a motherboard everytime I buy a graphic card.
  4. Quote:
    I`ve read the Asus forum and it seems that is an issue regarding ati new series and my motherboard.This is very frustrating cause there are a lot of users who experience this issue and no reply from ASUS support.

    Soon I plan to buy another motherboard cause I want to buy I7 and I`m sure that will not be an ASUS cause I don`t want to buy a motherboard everytime I buy a graphic card.

    Have you updated to the latest BIOS? That is usually where manufacturers fix such issues.
  5. Thx for the tip my friend but users from asus forum did already and nothing changed.....from what I understand they don`t suport not even 4xxx serie wich is an older 45 nm Process Technology.What`s strange is that Asus actually updated a bios to resolve this issue with the older 4xxx but for a cheaper model not for mine :)
Ask a new question

Read More

Radeon Compatibility SLI Graphics