Sign in with
Sign up | Sign in
Your question

Ati Asus EAH 5970 artifacts in crossfire mode

Last response: in Graphics & Displays
Share
March 30, 2010 11:26:57 AM

Dear tom's community,

Before I start explaining problems here is my current setup:

Processor: Core i7 920
MB: EVGA X58 (bios 49)
RAM: 3x2GB
Power: 1250W Enermax Revolution85+
Graphics: Asus EAH5970 (not OC)

Furthermore, I want to state that I used drivers form version 9.12 to 10.3 but it didn’t solve my problem.

Problem description:
Very simply stated, graphic card produces artefacts on the picture in all games that I play (Fallout 3, Mass Effect 1 and 2, Everquest 2, Metro 2033, Battlefield Bad Company 2, and probably more) when Crossfire is enabled.

When I am playing in the window mode, or when I disable Catalyst A.I. (which disables crossfire on this card) I have no problems. Games are running without any problem or any artifact on the picture.

Temperatures are also not a problem and I never noticed high temperatures even with playing whole day.

My PC system works 24/7 without problems or any glitches.

To solve this problem, I tried all possible solution that I could think of and read on forums.

I tried to change PCIE slot but it solved nothing.

I tried different v12 rails but again nothing (before Enermax 1250w which I bought thinking it will solve this problem, I had 750w power supply).

I also made clean install of Win 7, but it didn’t help.

Bios on the card is also latest form Asus.

Dear community, if you can think of something else that could help me please write.

If not, I am already preparing this card to be sent back. Luckily I have another card that will help me wait 3 to 4 weeks for RMA….

Thank you very much in advance.


Here are some screenshots of the problem in BBC2 and FO3. In other games it looks same.


By kuki1973 at 2010-03-30


By kuki1973 at 2010-03-30


By kuki1973 at 2010-03-30


By kuki1973 at 2010-03-30


April 6, 2010 8:19:11 AM

Hmmm most intriguing... just to be sure, have you checked the running temperatures of your components? Artifacting like that isn't necessarily a sign of overheating, but you never know...
April 6, 2010 9:12:25 AM

Hey there,

How do you enable Crossfire on a SINGLE 5970?

I believe Crossfire option only appears when you connect TWO video cards via Crossfire connector. If you are using a SINGLE 5970 then "crossfire" is already enabled. You shouldn't get a Crossfire tab in CCC.

Also, from my understanding, disabling AI DOES NOT disable Crossfire. It only limits performance.

What temps are you getting under load? Max sustained temps should not exceed 90C. 80-85C is normal.
Is there enough airflow in your case?
Have you OCed your CPU?
Is the card installed in the uppermost slot?
Have you used the regedit to change idle clocks for GPU2? (from 157/300 to 400/900)
Can you swap the card and drop it into another rig?

If it doesnt check out, RMA the card.

Good luck.
Related resources
Anonymous
June 16, 2010 11:14:09 AM

The 5970 ís a CrossFire card in itself. It incorporates two 5870 GPU's.
June 16, 2010 12:38:33 PM

One of the card can't keep up. Try to run single card (one 5970) and see which one will give you the problem.

Another quick check is to dial down the GPU clock. If the problem goes away then one card has an issue.

What case do you have? What is the room temp? What is your GPU temp. Normally one card has a higher temperature than the other.

You may end up RMA one of your 5970.
June 16, 2010 1:09:52 PM

First off the 5970 most definitely has crossfire and turning off catalyst AI definite disables the second core.

-----------------------

Have you tried upping the voltage on the cores. It might simply need more voltage since the 5970 used cherry picked cores designed to run at a lower voltage. Maybe the cores weren't as good as they hoped to be.
!