Sign in with
Sign up | Sign in
Your question

Serious stuttering in game with physics!

Last response: in CPUs
Share
July 3, 2010 12:36:13 AM

This could also be a GPU issue

First, my specs

i7 930 @ 4.0ghz
Sapphire 5970 stock
6gb G.Skill @ 1600
ASUS PX58D-E
Intel X25 80 gig SSD (this might be the problem)
Drivers 10.6 cats with app profile update (I also tried 10.4)

Okay so, the specific problem is that in any of the games I play there is some issue with textures stuttering.

There are also issues with Unigine heaven textures looking "off".

I just upgraded to this new i7 system, my old Q6600 did not have these issues, but it could be literally anything.

Anyways to be more specific, everything runs at very high framerates, but the stuttering is horrible. It's not stuttering with long pauses, its stuttering with very short clips.


Also, this is worth noting, this happens a LOT when anything with physics is happening or when 2d textures are loading.

An example is in the witcher menu the rain in the background is EXTREMELY choppy. When I start recording with FRAPS it becomes fine.

Bioshock ragdoll bodies are horribly choppy, in bad company 2 the physics seems to run fine, but when I try to use a scope, the black circle outline gets really choppy when moving. Yet the framerate stays high. I am usually pretty tech savvy about stuff but to this I am at a loss.

Please please give me some insight into this problem.

Thanks!
a c 131 à CPUs
July 3, 2010 12:41:14 AM

What components have you tried substitutes for so far to try to narrow down your problem?
m
0
l
July 3, 2010 6:40:22 AM

I've mainly tried changing drivers and reinstalling windows. I don't have another vid card so I can't change that. But it works fine on my old system. So I don't think it's the 5970, but I'm not 100%
m
0
l
Related resources
a c 131 à CPUs
July 3, 2010 5:36:32 PM

Spandy87 said:
I've mainly tried changing drivers and reinstalling windows. I don't have another vid card so I can't change that. But it works fine on my old system. So I don't think it's the 5970, but I'm not 100%

No other video card to test? So your old system used integrated or AGP then?
Try the hard drive from your old system. Let's make sure it's not an issue with the SSD (even though I don't believe it could be).
Let's see if it's an issue with the crossfire. There should be an option in the catalyst control center to not run your two chips in crossfire, thereby just using one 5970 chip as opposed to both.
m
0
l
July 3, 2010 6:51:00 PM

No I meant that when I used my 5970 in my old rig there was no stutter. K I will try the hard drive swap next. Thanks for helping me with this.
m
0
l
July 3, 2010 7:32:17 PM

Also, dipankar, it's not really short pauses. It's more like just texture stuttering, almost flickering (but it's not the regular kind). And ragdoll physics is very choppy and unnatural. It looks kind of like when there's a physics fps cap, but forcing vsync off or enabling triple buffeting doesn't help. Recording with fraps makes it work like it should, but that's only while recording with fps forced at 50. Unigine heaven was where I noticed the horrible texture flicker/stutter in the clouds and backgrounds.
m
0
l
July 3, 2010 9:46:22 PM

It's not the hard drive, I tried it with my old hard drive and its the same result.

Dipankar, that seems like an accurate description of whats going on. Where is the problem? How would I go about fixing it?
m
0
l
!