Sign in with
Sign up | Sign in
Your question

HDD Keeps Disconnecting from RAID 5 Array

Last response: in Storage
Share
June 4, 2012 8:43:22 PM

I recently built myself a new Z77 rig that includes 3 Seagate Barracuda st2000dm001 drives in RAID 5, connected to Intel's SATA 2 ports.

One of these drives keeps 'disconnecting' when I try to transfer large files (~80gb) to it from another networked computer. The transfer starts off fine but a few minutes into the transfer will slow to a crawl and I'll get the error stating that the disk on port x is no longer there. Changing which port the sata cable is connected to corrects the issue for a while, but it keeps randomly dropping off and I keep having to rebuild the array after the drive in question is subsequently 'found' again. I have tried replacing the sata cables with different ones but the issue persists. I have also tested all three HDD's using SeaTools (DOS) long test and all three passed with no errors. Also it does not affect a specific drive, and the drive that disconnects is random (identified by the serial number in the Intel Rapid Storage Technology interface.) Changing which ports the drives are connected to seems to have no effect on this error either, and I am getting very frustrated as I can't seem to track down the cause. What could be causing this? The connections all seem good when I switch ports so I'm wondering if it might be the ports themselves or maybe a faulty motherboard or something?

MOBO: GA-Z77X-UD5H with firmware F7
OS Drive: Crucial M4 256GB with firmware 000F
Data Array: 3x ST2000DM001 in two RAID 5 arrays (backup OS and storage) on intel SATA 2 ports, all with firmware CC4C

The event viewer lists the same error for all occurances and comes from iaStor (the Intel Rapid Storage Technology driver/software). The error is as follows: The device, \Device\Ide\iaStor0, did not respond within the timeout period.

Any help would be greatly appreciated, thanks!
June 7, 2012 4:44:45 PM

fantastik250 said:
Have you updated the Intel Rapid Storage Technology driver?

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...(Intel+RST)%22&lang=eng


Thanks for the link, but yes I am using the latest version of the Intel Rapid Storage Technology driver specific to my board, which is actually newer than the versions from that link (11.1.0.1006 vs 10.8.0.1003).

I believe I have solved this issue by applying the LPM registry modification described here: http://www.overclock.net/t/1069063/fix-for-irst-lock-up...

This disables the link power management feature that is enabled by default in versions 10+ of Intel's Rapid Storage Technology driver, and apparently can sometimes cause issues with some SSD's as well as RAID arrays.

After applying this registry modification to disable LPM for all 6 native (Intel) SATA2&3 ports on my Z77 board, I am no longer experiencing this issue of hard drives dropping from the array.

Hopefully this will help others who might be experiencing the same problem, but I notice that unfortunately I can't select my own reply as the best answer.
m
0
l
a b G Storage
June 7, 2012 10:55:57 PM

Oh I think that's good. I've seen others where their RAID setups don't work for some unknown reason.
m
0
l
!