Sign in with
Sign up | Sign in
Your question

Radeon 5750 install problems

Last response: in Graphics & Displays
Share
April 1, 2010 4:53:19 AM

I just purchased an XFX ATI Radeon HD 5750. I installed it in my AMD Athlon II x3 system with 4 Gb Ram, on MSI 785GM-E51
motherboard. I have a 420 watt power supply as well. I used CPU-Z and it shows the 5750 is there. Windows on the other hand continues to only show the on board HD4200. I have tried installing the drivers from the disk that came with it, ones from ATI and ones from XFX. Every time i tell catalyst to install i get a windows compatibility assistant window that pops up and the install fails. I am lost here and would love some help.
April 1, 2010 5:05:39 AM

Go in BIOS and disable the onboard graphics.
m
0
l
April 1, 2010 5:09:42 AM

I tired that. When windows booted up it installed the 4200 again.
m
0
l
Related resources
April 1, 2010 5:13:58 AM

Unless you're planning on using 4 or more monitors, what you need to do is go into the BIOS and disable the on-board graphics. Once that's done, hook up the monitor cable to the 5750 and reboot. From there, the rest is software related.

Go to http://game.amd.com/us-en/drivers_catalyst.aspx and download the ATI Radeon Drivers corresponding to your Operating System. Get the full download.

Go into Control Panel and click Uninstall a program (Vista, Win7) or Add/Remove Programs (XP). Find the ATI Catalyst Install Manager and click Uninstall or Change/Remove. Follow the on-screen instructions to remove ATI Display Driver and Catalyst Control Center. Once it's removed, you'll need to reboot your PC.

When back to the Windows desktop, find and run the ATI Catalyst Display Driver package you downloaded and run it. This is the Setup program, and it will extract itself where instructed. Once extracted, run the Setup.exe within it. You should install all options other than the option freebie LoTR trial and registration. (Register your card with XFX separately.) Once that completes, your system will require another reboot, and from there you should be good to go.
m
0
l
April 1, 2010 5:14:44 AM

There is one option in some BIOS versions where you can select the VGA device to initialize first. Choose option PEG or PEG1 if they are available.
m
0
l
April 1, 2010 5:17:33 AM

I went back to my bios and made sure the onboard was disabled. It is. My cable is connected to my 5750. And when I booted back into windows 7 professional it detected the hardware and shows a hd 4200 again. I looked in my add/remove programs and catalyst is not listed anywhere in there. When i bring up CPU-Z it shows the 5750 as the graphics card. I also made sure my bios is set to PCI-E as primary adapter.
m
0
l
April 1, 2010 5:32:27 AM

What does Device Manager show the Display Adapter as? If it says 4200, right click it and go to Properties. Click the Driver tab and Uninstall the driver. Reboot and see what it calls it then. It should either ID it properly or call it a VGA adapter. At which point you should install Catalyst 10.3 driver package.
m
0
l
April 1, 2010 1:46:57 PM

Device manager says their is a standard VGA adapter and the 4200. If i remove both and reboot windows still loads the 4200 even when its disabled in the bios and I am connected to the 5750. I used driver sweeper to remove the ATI stuff. Still cannot get the catalyst drivers to install.
m
0
l
April 1, 2010 1:57:43 PM

Make sure you plugged you Monitor into the slot of 5750 ! If not plug it !
m
0
l
May 3, 2010 3:48:46 AM

uninstall the 4200 from device manager. uninstall catalyst controller (very important!!!). reboot. disable the onboard vga in bios. boot to windows. install driver for your 5750 card. this will also reinstall catalyst controller.
m
0
l
!