Sign in with
Sign up | Sign in
Your question
Solved

Raid 0 array droped: Windows 7 installation

Tags:
  • NAS / RAID
  • BIOS
  • Windows 7
  • CPUs
  • Motherboards
  • Storage
Last response: in Storage
Share
June 8, 2012 4:49:23 AM

I recently upgraded to a new AM3+ bulldozer FX-8120 from an AM3 Phenom II x4 955. My motherboard was a M4A89TD PRO/USB3, which meant I had to do a BIOS upgrade. Support for AM3+ CPUs is currently in beta, and their hasn't been a newer BIOS in over 6 months.

Before buying this new CPU, I had 3 60GB SSDs from OCZ in RAID 0 together.
After buying this new CPU, I decided to nuke my OS, because I've had problems in the past when upgrading CPUs without re-installing windows.

I upgraded to the newest AM3+ beta BIOS for my motherboard, and then I re-made the RAID array, and I began the Windows 7 setup. Using a USB drive, I selected the RAID drivers, and then the RAID 0 drives.
Instillation began but, about halfway through, I was given a message that Windows could not find the disk (I no longer remember the exact message).
Upon going into the BIOS, I was told that one of the drives was inactive. I remade the RAID array and tried again several times, using different Windows7 DVDs from friends and different RAID drivers that came in my MOBO's RAID driver zip.
Their were different RAID drivers inside 3 different folders: AMD, JMB36X, and JMB361. Inside AMD, you could select OS and architecture (x64 or x32). Inside JMB36X and JMB361, you could only select architecture. Unfortunately, none of these combinations worked.

Giving up the battle, I installed windows 7 onto just one SSD. Within windows, I now have data on each of the 3 drives, and they all appear to be functioning correctly.


Does it sound like it would be worth my time to try again?
Do I need to wait for a new version of the BIOS?
Could their be a way for me to create the RAID array and transfer my data to it outside of windows?
Should I test to see if I can make a RAID 0 hardware array with my other 2 drives before trying this all again?

Any help/feedback/questions/clarifications would be greatly appreciated

More about : raid array droped windows installation

a b $ Windows 7
a b V Motherboard
a c 545 G Storage
June 8, 2012 6:47:30 AM

In the RAID BIOS does the same drive come up inactive every time you attempt the Windows install? If so, remove that drive from its current port and connect it to another; see if that works.

Also, have you tried installing Windows without pre-installing the RAID drivers? Just letting Windows install its own default RAID drivers? If that works you could then install AMD's latest RAID drivers after your system is stable.
m
0
l
a b $ Windows 7
a c 206 à CPUs
a c 490 V Motherboard
a c 138 G Storage
June 8, 2012 7:13:37 AM

also did you check the firmware on the ssd. are they the same and are they up to date. also did you check the drives using the vendor ssd fitness tools.
m
0
l
Related resources
June 8, 2012 2:12:14 PM

I believe the same drive came up inactive each time, so I will attempt swaping ports around.
And regarding Windows built-in drivers, it did not detect my hard drive unless I selected the RAID drivers, so that option is off the table.

My 3 SSDs were all on the same firmware version, but their is a newer version.
I will now update firmware, and swap ports around to try and get it to work with 3 drives. If it continues to refuse to work with 3 drives, I'll see if its stable with just 2...
m
0
l
June 8, 2012 8:28:21 PM

The SSD firmware update was successful, but the install was not.

When selecting drivers, I got the message that 'Windows will not install unsigned drivers'. I looked on the web, and found that I could enter a mode that would accept unsigned drivers.
Dispute this, it continued to not accept my 64 bit drivers. I then tried the 32 bit drivers, just to see what would happen.
Using 32 bit drivers, it had the same error, but decided to show the RAID anyway. However, upon trying to install to the RAID array, i got error code 0x80300024.
The drive was fully unallocated. I got the same error while the drive was fully allocated, and when I had set aside a 100GB boot partition for windows 7.

I was using copies of the drivers both from the original CD, and downloaded from ASUS's official page.



Any other pieces of advice would be welcome. I'll be keepin it nuk'd/uninstalled for the next several days to try new things with it.
m
0
l

Best solution

a b $ Windows 7
a c 206 à CPUs
a c 490 V Motherboard
a c 138 G Storage
June 9, 2012 12:29:39 AM

http://support.amd.com/us/gpudownload/windows/Pages/rai...
newest raid and achi drivers there newer then asus ones.
Share
June 9, 2012 6:44:53 AM

That did the trick!
It still gave me the 'Windows will not install unsigned drivers' message, but it installed without a hitch.

Thank you everyone for your help.
m
0
l
June 9, 2012 6:46:05 AM

Best answer selected by Schroeder.
m
0
l
!