Sign in with
Sign up | Sign in
Your question

First attempt to access to Linkstation is slow in Windows 7 x64

Last response: in Networking
Share
a b $ Windows 7
February 17, 2010 10:42:31 PM

I have a Buffalo LS-320GL Linkstation connected via gigabit Ethernet to my Netgear DIR-655 wireless router. Ever since installing Windows 7 x64, the first access to the NAS takes around 20 seconds for it to respond. After the first access, subsequent accesses are quick and normal for the remainder of the computing session. This problem doesn't occur in XP x86 or Vista x86.

Both my desktop and my laptop experience this problem. Both are running Win 7 x64. The desktop has a gigabit card, the laptop is wireless N. Could anyone shed some light on what might be happening and a possible remedy?

More about : attempt access linkstation slow windows x64

February 17, 2010 11:12:59 PM

Normally I would attribute such a delay to the NAS having to spin up the HD after it’s been idle for an extended period and spun down. I wonder if maybe you tried to access it w/ Win7, it spun after 20 seconds, then you immediately went over to the XP or Vista machine and checked. Of course, it has already spun up at that point.

I just want to be sure you checked w/ XP or Vista *first*, then immediately went to the Win7 machine. You might also check if the spin down can be disabled and see if things return to normal.

At least that's my initial suspicion.
m
0
l
a b $ Windows 7
February 17, 2010 11:28:28 PM

eibgrad said:
Normally I would attribute such a delay to the NAS having to spin up the HD after it’s been idle for an extended period and spun down. I wonder if maybe you tried to access it w/ Win7, it spun after 20 seconds, then you immediately went over to the XP or Vista machine and checked. Of course, it has already spun up at that point.

I just want to be sure you checked w/ XP or Vista *first*, then immediately went to the Win7 machine. You might also check if the spin down can be disabled and see if things return to normal.

At least that's my initial suspicion.

No, eibgrad, I don't believe that's the problem. I've used the NAS w/the other OSs for years and never came across this issue. It's only when accessing it in Win 7 x64. My desktop, for instance, is set up for dual booting both that OS and XP Pro x86. When I'm in XP, there is never a problem; on the initial acces or later ones. In Win 7, always. And, unfortunately, the Buffalo NAS has no sleep mode either.
m
0
l
Related resources
February 17, 2010 11:41:39 PM

Hmm, ok.

Sounds to me like the protocol stack is doing “something”, then times out, and moves to the next thing, then finds the NAS. The first “something” that comes to mind is name resolution. Are you perhaps attempting to access by NAME rather than IP address? Maybe that name resolution (beit Windows or DNS, not sure which you’re using) is different on the Win7 network stack. I’ve even heard of ppl have problem w/ the presence of the IPv6 protocol stack, a bit buggy. You might try uninstalling it since almost no one is using it anyway. Just another opportunity for things to go wrong.

Anyway, that’s what it seems like, like it’s searching for something or trying to resolve something, like the device name. If you haven’t already, just try w/ an IP address.

m
0
l
February 17, 2010 11:49:13 PM

P.S.

I would also clear the ARP table:

netsh interface ip delete arpcache

... and clear the DNS cache:

ipconfig /flushdns

... and reboot for good measure.
m
0
l
a b $ Windows 7
February 18, 2010 12:38:56 AM

eibgrad said:
P.S.

I would also clear the ARP table:

netsh interface ip delete arpcache

... and clear the DNS cache:

ipconfig /flushdns

... and reboot for good measure.

I'm afraid you've gone over my head with that explanation. I'm not a professional user, just an average home user. Maybe a more detailed step-by-step explanation for a layman? ;-)
m
0
l
February 18, 2010 1:04:32 AM

clutchc said:
I'm afraid you've gone over my head with that explanation. I'm not a professional user, just an average home user. Maybe a more detailed step-by-step explanation for a layman? ;-)


oh, sorry.

Start->Run, then type "cmd" (no quotes), and it will open a command window. Now execute these commands:

netsh interface ip delete arpcache
ipconfig /flushdns

Don't worry about what they do right now, they just clear some tables associated w/ your network connection. It just makes sure that you're starting w/ a CLEAN SLATE as you try to resolve your problem.

m
0
l
August 13, 2012 11:38:33 PM

I had this exact problem on a Lenovo x201/i5 and Asus Rampage Formula w/core2 core2 quad. Both machines are running win7x64 professional. Both machines have 8GB of ram.

Fix: in the network adapter protocols, uncheck the following:

1) TCP/IPv6
2) Link Layer Topology Discovery Mapper I/O Driver
3) Link Layer Topology Discovery Responder

I suspect 2 and 3 were causing the problem. I disabled tcpip v6 because I didn't need it. Now remote file system on my LAN are loaded in less than 5s - usually a lot faster. :) 

I hope this helps someone.
m
0
l
a b $ Windows 7
August 14, 2012 3:05:27 AM

eibgrad said:
oh, sorry.

Start->Run, then type "cmd" (no quotes), and it will open a command window. Now execute these commands:

netsh interface ip delete arpcache
ipconfig /flushdns

Don't worry about what they do right now, they just clear some tables associated w/ your network connection. It just makes sure that you're starting w/ a CLEAN SLATE as you try to resolve your problem.

Unfortunately, that didn't help.
m
0
l
a b $ Windows 7
August 14, 2012 3:08:52 AM

digital_27 said:
I had this exact problem on a Lenovo x201/i5 and Asus Rampage Formula w/core2 core2 quad. Both machines are running win7x64 professional. Both machines have 8GB of ram.

Fix: in the network adapter protocols, uncheck the following:

1) TCP/IPv6
2) Link Layer Topology Discovery Mapper I/O Driver
3) Link Layer Topology Discovery Responder

I suspect 2 and 3 were causing the problem. I disabled tcpip v6 because I didn't need it. Now remote file system on my LAN are loaded in less than 5s - usually a lot faster. :) 

I hope this helps someone.

Just tried that. Didn't help. Re-booted and still didn't help. Since I wrote this thread, I have since re-installed just Win7 (no more dual boot). The NAS is quick to respond until the drive sits for awhile. Then it takes 20-25 seconds to display its contents. After which it is good untill I allow it to sit for awhile unaccessed again. However, if I leave window to the drive open, it can be accessed normally. This happens with every Win7 machine I've used with it, wired or wireless. And I've used a lot.
m
0
l
!