Sign in with
Sign up | Sign in
Your question

Failed to boot after RAM downgrade!!

Last response: in Memory
Share
January 10, 2011 8:14:35 AM

Hello guys,

I strange incident happened to my computer:

I originally used 2x1GB RAM on my computer, but then i upgraded it to 2x2GB RAM without any problems. However, when i tried to used 2x1GB RAM again, I found the computer failed to boot with three, I suppose, long beeps. The screen is blank but the 2 fans are working. so as the other components. Anyone knows what happened?

Thanks in advance!! :D  :D 
January 10, 2011 9:26:45 AM

I think one of your ram stick has failed. Try checking them 1 by 1 at a time when booting your pc. By the way are all your ram stick identical?
m
0
l
January 10, 2011 11:21:30 AM

dry joints most likely - clean the connectors

RP7 or WD40 on a clean brush, paint the pins and sockets/connectors - works a treat
m
0
l
Related resources
January 10, 2011 11:28:00 AM

venjhammet said:
I think one of your ram stick has failed. Try checking them 1 by 1 at a time when booting your pc. By the way are all your ram stick identical?



Thanks for your reply. The two 1GB RAMs and the two 2GB RAMs are identical.
m
0
l
January 10, 2011 11:30:11 AM

apache_lives said:
dry joints most likely - clean the connectors

RP7 or WD40 on a clean brush, paint the pins and sockets/connectors - works a treat


Thanks for your reply. Is it a must to use chemical to clean the connectors? Will it lead to further malfunction of the RAM sticks? Or maybe I should use water??
m
0
l
!