Windows 7 64bit only showing 4gb Ram

Hello!

I recently put my computer together for the first time and got it working. However there is one thing I've noticed as a problem I'm unsure how to fix.


I have 12gb 1333 Gskill ddr3 ram and windows is only picking up 4gb's of it. Bios see's all 6 sticks but it doesnt say how much each one is just a total of 4000mb memory.


I have a asus rampage iii motherboard and the ram is on the approved list according to the book. I don't know what setting to mess with since most of them are dedicated overclocking settings. And I just want my ram to show up.


Also on a offhand note, I'm getting CPU Fan Error when I boot up however every fan in the case and on the cpu are working fine is this because I picked random places to plug the fans into?

Any advise or questions would be awesome
13 answers Last reply
More about windows 64bit showing
  1. I'm going to guess I don't... I'll have to check at home this afternoon. how do I go about doing that?
  2. What kind of memory kit is it you are using, is it a 3x4 GB? If so, are you using the memory in the first 3 slots left to right? If yes, then that is where the problem lies.

    If you have the memory in the correct slots, try them all one at a time to verify that they all work, and we can take it from there.
  3. its a full hex kit 6x2gb sticks. they're all in and Bios picks them up something being in CHAA CHAB BA BB CA CB.


    Do I want the maximum memory box checked or unchecked?
  4. va7enkeist said:
    its a full hex kit 6x2gb sticks. they're all in and Bios picks them up something being in CHAA CHAB BA BB CA CB.


    Do I want the maximum memory box checked or unchecked?


    Having it unchecked will have the OS use all available memory.

    Edit: Just to make sure, you have checked that you do have 64 bit installed and not the 32 bit version?
  5. I'll check when I get home. I'm almost positive i have 7 home professional 64.
  6. hello checked yesterday but wasnt at work so i forgot about this.

    It is 7 home proffesssional 64 bit it's the OEM system builder version I dont know if that has any impact..

    Max Memory box was unchecked.

    Still only have my 4gigs


    Asus rampage iii
    hd radeon 6970 xfx video
    12 gb of Gskill 1333hz DDR3 ram all from the same kit.
    I7 3.07 Bloomfield Quad cpu I haven't OC'd yet cuz of that random fan error that doesnt really seem to be a error.
    Thermal Take _____ heatsink
    Lian-Li Armorsuit Case with 4 Fans
    Ocz 750w PSU
    Samsung SSD 64
    seagate Barracuda 1tb
    _____ CD/Dvd r+w
  7. Checked it and it has a max of 4096mb I unchecked it afterward assuming thats what you're talking about.
  8. http://dlsvr.asus.com/pub/ASUS/mb/LGA1366/Rampage_III_Formula/e5997_Rampage_III_Formula.zip?bcsi_scan_1331D36F92DEEEED=1

    Like where should the cpu fan be plugged in? I have it right by the 24 slot psu connector.

    EDIT

    wrong manual fixed
  9. Any other ideas from anyone? Not sure what to do from here.
  10. I tried taking out the ram and It wouldn't boot... I tried a triple channel set of 6gb and nothing happened so I went back to 12gb displaying as 4. i didnt try 1 stick at a time since 3 didnt work i wasnt sure if i should do one at a time
  11. since its an asus mb i suggest you read tru this : http://vip.asus.com/forum/view.aspx?id=20100429194317906&board_id=1&model=P6X58D+Premium&page=1&SLanguage=en-us its a sticky on the asus forum
  12. Quote:
    ^
    good question on the 32-bit or 64-bit...

    what are the rest of the specs.?



    He said 64 bit derp
  13. This is a YEAR OLD Thread. OP is long gone.
Ask a new question

Read More

Memory Windows 7 RAM