Sign in with
Sign up | Sign in
Your question

Quad core only using 1 core

Last response: in CPUs
Share
July 5, 2010 11:16:32 PM

Hello, I'm not sure if this is the right place to ask but I recently bought an AMD Athlon II 630 x4 cpu and an MA785GM-US2H Gigabyte motherboard. I installed everything smoothly however when I turn my pc on my computer only uses 1 core. I'm not exactly sure how to fix it so it uses all 4. I have run CPU-Z and checked my task manager to effectively know that I am only using 1 core and looking through my BIOS I don't see any information about activating cores or what not. Any help would be appreciated.

More about : quad core core

a c 131 à CPUs
July 5, 2010 11:27:59 PM

If any cores were disabled, or windows could not use a core, it would not appear in the task manager. I don't quite follow how you come to the conclusion that only one core is being used by windows.
m
0
l
July 5, 2010 11:30:58 PM


What Windows operating system are you using and did you do a fresh install on your system after putting in the new CPU? If it is Windows XP it could be a HAL problem.
m
0
l
Related resources
July 5, 2010 11:38:24 PM

check in your bios for advanced clock calibration, activated the unlishing mode, and set it to manual. This will allow you to select how many cores you want to use (at least in my asus bios I have this option.

btw, in task manager you get only one graphic on "CPU history usage" or you have 4 and only one shows activitie?

A bios reset might help.
m
0
l
a b à CPUs
July 5, 2010 11:43:24 PM

update to l8est bios
m
0
l
a c 471 à CPUs
July 5, 2010 11:54:23 PM

When you go into Task Manager do you see all 4 cores or just 1core?

You also need to realize that having a dual or quad core CPU (tri core as well) does not automatic mean all core will be used. Games and programs must be coded to take advantage of multiple cores (multi-threading).

For example, when playing Fallout 3 on my quad core Q 9450 at most my Q9450 is only using 31% capacity. That means Fallout 3 is not a multi-threaded game and does not even require a dual core CPU. FO3 uses 25% of my CPU while background processes uses the remaining 6%.

However, when encoding MKV file using the X.264 codec and Handbrake, my CPU usage is nearly 100% at all times. When I encode videos for my Cowon S9 portable media play using DivX or Xvid then my CPU has a load of about 50% because those codec are programmed to take advantage of two cores, but not four cores. Just as well I suppose 'cause that means I can play FO3 while encoding video at the same time.
m
0
l
July 6, 2010 12:22:59 AM

When I go into Task Manager I only see 1 core and I have it set to 1 graph per CPU which is what leads me to believe i'm only using 1 out of my 4 cores. I have tried all that was mentioned above except a fresh install yet to no avail.
m
0
l
a c 471 à CPUs
July 6, 2010 12:40:04 AM

I see....

What BIOS version is your motherboard? It seems you need at least version F8 for the mobo to recognize the AMD Athlon II 630 x4 cpu.
m
0
l
July 6, 2010 2:00:11 AM

I am using version F9 so that should not be the problem either.
m
0
l
a c 471 à CPUs
July 6, 2010 2:32:52 AM

Hmmm.... sounds like a re-install.

What does CPU-Z say?
m
0
l
July 6, 2010 2:48:54 AM

CPU-Z also says that I'm using 1 core.
m
0
l
a c 471 à CPUs
July 6, 2010 3:43:20 AM

At this point I recommend a re-install.

If only one core still appears after the re-install, then you're gonna have to call Gigabyte tech support or maybe do an exchange on your mobo if you bought it recently. Unless of course the issue is with the CPU...

Sorry, but I don't know what else to suggest.
m
0
l
a c 131 à CPUs
July 6, 2010 4:05:40 PM

What information about the CPU does the bios detect?
m
0
l
July 6, 2010 5:10:24 PM

stickman52 said:
CPU-Z also says that I'm using 1 core.

Hi
I think you should update your bios also reinstall your windows, this is because i have heard that the os have problems showing more cores on upgrade. u reinstall the windows so i think then it will work. also update the bios as i remembered that my friend bought a q9400 and when he inserted the cpu, the bios didnt detected the correct speeds and etc. so he updated the bios and the problem was solved. hope i helped
m
0
l
July 6, 2010 7:36:57 PM

ricno said:
What Windows operating system are you using and did you do a fresh install on your system after putting in the new CPU? If it is Windows XP it could be a HAL problem.


I think it would still be interesting to know the above. What is your OS and have you kept the same installation after the CPU change?

If it is an older OS there is something called "HAL" that could cause problem. The Windows Hardware Abstraction Layer DLL is chosen at installation and could be uni-processor or multi-processor, and it will not change automatically when you add more CPU's or cores.
m
0
l
!