Sign in with
Sign up | Sign in
Your question

Computer would not power on with new ram

Last response: in Memory
Share
January 11, 2011 2:47:41 AM

Hello all,

So I recently purchased new memory for my Toshiba Satellite A105-S1712. When I installed the stick and reassembled my computer, the power light would come on, I would hear the fan start, then the light would go off and the fan would stop, then the process would repeat about 4 or 5 times before the computer shut down altogether. What is the problem? I made sure the new module was the same speed and had the exact same CL as the original, so everything seems to be compatible, and I made sure the ejector clips closed properly and the module was completely inserted, but still my computer does what I said earlier. What could be the problem?

More about : computer power ram

a b } Memory
January 11, 2011 6:11:48 PM

If you installed the new modules correctly, then it sounds like you got bad RAM. You could send it back for replacement RAM.
m
0
l
January 13, 2011 2:49:08 AM

huh... what are some common mistakes though, cuz I wanna be sure it's not just my own mistake. like i said, I made sure the ejector pins were locked on it and it was inserted all the way, so is there anything else to check for? i made sure I was grounded and everything.
m
0
l
Related resources
January 13, 2011 2:50:51 AM

one other question i had, this module has a heat spreader on it (i think) would that be getting in the way? cuz the module installed now is bare, so is that a problem?
m
0
l
February 9, 2011 2:35:31 AM

Best answer selected by jg3220.
m
0
l
!