Realtek Problems?

The motherboard is a p35-ds4 of gigabyte and i have onboard sound with realtek hd audio manager. so when i restart the computer or switch it on after shutting it down... it sometimes fails to recognize the 5.1 speakers i have plugged in behind nor does it recognize the headset which i connect through the front. but instead it shows s/pdif in and out ( digital in and out ) as being active.

This is usually fixed by restarting the computer after which it automatically recognizes the 5.1 and forgets the digital. but today, i've restarted it 4 times and still doesnt care about the 5.1.... how do i fix it?

P.S. i do not know what is connected into digital nor do i know from where to connect ! its my brother's computer
13 answers Last reply
More about realtek problems
  1. could u tell me how to turn off the digital plz?
  2. Ha ha you're killing me dude!
    I put a sound card in both my new rigs and no longer use onboard.
    Somewhere in your sound settings you'll see s/pdif uncheck it.
    Control panel/ Sound/playback/ enable whatever device you want
  3. lol thank you and love u soo much!! :P, if it doesnt work out i think im going for the soundcard way too!

    have a nice day!!
  4. Honestly though the easiest way to fix your sound is to update the drivers
    during installation just don't check digital
    too easy
    digital is for external hometheatre set-ups
  5. disabled the digital and tried to choose a playback device and realtek went "hey let me check whats ur problem" and found a sound blaster 5.1 that was disabled... i had a soundcard inside and my bro wasnt using it.. dunno why though! (sound blaster 5.1 )
  6. update :- mic doesnt work on it! NOOOOOOOOOOOOOOOOOOOOOOOOOO
  7. blahhhhhhhhhhhhhhhhhhhh NOTHING WORKS ON THE SOUND BLASTER EXCEPT THE GREEN PORT
  8. squallypie said:
    disabled the digital and tried to choose a playback device and realtek went "hey let me check whats ur problem" and found a sound blaster 5.1 that was disabled... i had a soundcard inside and my bro wasnt using it.. dunno why though! (sound blaster 5.1 )

    The most helpful piece of info you left out is what os you're using.
    Plus if not set-up properly all the system is doing is conflicting.
  9. its windows 7 ( 32 bit ) and i reinstalled realtek software once but got a bsod before the computer restarted. so i had to install it again after downloading another fresh copy off the internet ( from gigabyte for windows 32 ) and it installed fine, except that it didn't give me any options to disable.

    So now i have it again still on digital mode, no analog (5.1)...

    but on sound blaster 5.1, only the green jack works... the rest wont work... does it need the drivers to work?
  10. squallypie said:
    its windows 7 ( 32 bit ) and i reinstalled realtek software once but got a bsod before the computer restarted. so i had to install it again after downloading another fresh copy off the internet ( from gigabyte for windows 32 ) and it installed fine, except that it didn't give me any options to disable.

    So now i have it again still on digital mode, no analog (5.1)...

    but on sound blaster 5.1, only the green jack works... the rest wont work... does it need the drivers to work?

    Yes uninstall all the Realtek stuff
    You have to install the latest drivers for that card
    Have fun i hate creative drivers
    good luck!
  11. thank you, the driver for my card is on beta mode for win 7 -.- so i dont want to risk it coz i might get killed by my bro :$
  12. update :- after shutting it down in the night and switching it on in the morning, it magically recognizes analog again, ( the realtek ).. hurray! its all good now!
Ask a new question

Read More

Sound Cards Realtek Computer Components