Sign in with
Sign up | Sign in
Your question

Intel 1000 GT unable to connect at Gigabit speed

Last response: in Networking
Share
February 18, 2010 5:32:34 AM

I just bought an Intel 1000 GT ethernet card, but I can't get it to connect to my switch at Gigabit speed. Both computer (Win2003) and switch (Netgear gs608) show 100Mbit. Other machines connected to the switch have no problems using gigabit. I first let Windows find drivers automatically which it did, but no gigabit. I then downloaded the latest Intel driver and installed that, but still no gigabit.

Any ideas?
February 18, 2010 11:52:05 PM

Are you sure the cable is at least CAT5e (CAT5 won't work). Just to be sure, swap cables w/ another PC that's successfully running 1000mbps.

If need be, you could go to Device Manager, locate the adapter, right-click and select properties, and reconfigure the driver w/ a fixed 1000mbps rather than relying on auto-sense. Shouldn’t be necessary, but I have seen this work in a few stubborn cases.

It’s even possible that 1000mbps isn’t listed, which would indicate it’s either not using the correct driver, or maybe 1000mbps isn’t available w/ that driver on that OS.

February 19, 2010 5:35:01 AM

I have tried with 2 CAT6 cables, one of them 3 meters and the other 5 I think, same result.
In the driver I can set Auto detect, 10Mbps half or full duplex, 100Mbps half or full duplex, Auto-negotiate 1000Mbps. Right now it's on Auto detect and the Link Status says 100Mbps Full Duplex. I have tried setting it to Auto-negotiate 1000Mbps but it doesn't help.
The driver is for WinXP and Win2003 32bit.
I tried the Diagnostics in the driver properties and it reported "The cable connected to this port is missing pairs needed to connect at 1000Mbps". Which is strange as I used this cable with my previous ethernet card and it worked fine at 1000Mbps. To be sure I tried a third CAT6 cable, but same result.
Hardware diagnostics on the card shows nothing wrong.
Related resources
February 19, 2010 10:37:08 AM

Have you tried a different port on the switch?
February 19, 2010 3:47:34 PM

Yes I've tried several different ports
February 19, 2010 5:58:36 PM

Take a look at the nic card. In the connection you should see 8 little wires angling up from the front towards the back. Make sure they appear to angle smoothly and are equally separated from each other. Any bent ones will cause connection issues.
September 17, 2012 12:59:12 PM

I had the same issues (same switch/same NIC). I moved the cable over to my NetGear router that has four Gbit ports. Once I did this, using the same cable, it auto-sensed at a Gbit speed. Must be something with the cheap NetGear 10/100/1000 switch. I have other Gbit NICs plugged into the NetGear 10/100/1000 switch too and only one port is auto sensing correctly. I wonder if the switch is fried?
!