Sign in with
Sign up | Sign in
Your question

Weird problem with ATI 5770

Tags:
  • Graphics Cards
  • Overclocking
  • GPUs
  • Graphics
Last response: in Graphics & Displays
Share
April 2, 2010 8:20:39 PM

Hi all

I'm having the notorious GPU error message "ATIKMDAG Stopped Responding, Then Recovered" BUT only when I overclock the CPU.

The problem is causing my system to either go on the blink or hang-up (Tom's article refers to it here: http://www.tomshardware.com/reviews/2d-windows-gdi,2539... and it is all over various forums).

I need some help understanding why I get the problem and more importantly, how I'm going to fix it, because it isn't happening when I'm at stock and I don't have low idle clocks at 2D.

See, the thing is, it only happens when I overclock the CPU. The overclock is only to 3.6 gHz to an i5 750 on a Gigabyte P55M-UD2 board, and its stable in everything else like Prime95, IBT, etc. I tested the GPU in Furmark when the CPU is overclocked and it runs 10 minutes no problem. The GPU has not been overclocked and I have new CCC 10.3 installed (same result as 10.2

Other relevant specs: W7 64bit, 212+ cooling, Crucial DDR3 1333 1.5v ram 2 x 2 GB, temps aren't a problem anywhere, all drivers and bios up to date.

I don't get the problem when I'm at stock settings on the mobo and CPU, and the problem only occurs in the 2D environment i.e. at the desktop.

Most people who have solved the problem have noticed that the GPU idles at around 157 clock in 2D environment and the fix seems to be to set idle at higher clock. However, I noticed that all threads I have read are for problems where people aren't necessarily overclocking. And also, I observe ATI overdrive and GPU-Z that my card idles at 400 anyway (which is where people recommend setting min. idle).

I don't want to give up my overclock and I want my GPU to be stable in 2D as this is the last problem (fingers crossed) for a stable system that I can then forget about.

Can anyone help me out please ?? Much appreciated in advance.

More about : weird problem ati 5770

a b U Graphics card
April 2, 2010 8:33:28 PM

It sounds like as you are overclocking you are causing instability with something, but not your CPU. Remember, when you bump the base clock, you are affecting not only your CPU, but your FSB, your RAM, your chipset, etc. It could easily be that even if your CPU core is stable and your RAM is fine, the PCI-e lanes and stuff are integrated on the CPU and maybe some of THAT doesn't like the higher clocks.
This means, you may just not be able to OC your board as far, or you need to raise some voltages a bit to get that stable (I'm not positive, but maybe the PCH voltage increase would help?)
April 3, 2010 9:52:15 AM

Thanks for the reply.

Any others have the same sort of problem who has solved it definitively ?

At the moment, I have a few too many options to try in addition to the tweaking of various o/c settings. These include:

- running my 1.5v memory at 1.6v (according to XFX helpdesk email I saw)
- turning off Aeroglass in W7 desktop (suggested by Toms in the article above,and others)
- setting profile in CCC and setting a minimum idle clock & memory (maybe my clocks do dip down too low but I haven't seen it)
- rolling back drivers, way back (seems to have worked for some)
- overclocking the 5770 a touch (worked for a few)
- there are a few more minor things I've seen suggested too

Problem for me is that I don't know where to focus on these because as I said, I don't have the problem at stock settings, and therefore, I'd rather focus on getting the o/c right.

But what o/c settings could affect the GPU blacking out in 2D

And how can I tell if I have to do any of the other stuff like turn off Aero, etc.

Thanks again
Related resources
a b U Graphics card
April 3, 2010 10:08:48 AM

You probably overclocked your PCIe bridge as well. Look here, maybe this helps:

http://www.atikmdag.com/
April 3, 2010 10:24:22 AM

in your bios, lock the pcie to 100 MHz, not automatic
it will probobly solve the problom
April 3, 2010 10:57:13 AM

Thanks for both of your (the last two) replies, and keeping the thread going.

I appreciate the suggestions too, and reading up on the atikmdag problem page, I agree that it is a very generic error message. I have already, by default, done a few of the things suggested, including updating the drivers.

However, I'd like to follow up on the idea that the PCI-e has been affected by my overclock. I have already actually set the clock rate to 100 rather than leaving it at Auto. Is it possible I need to bump it even more ? Maybe a stupid question, but I haven't a clue about what range of settings is OK for this parameter.

Also, I will follow-up the suggestion about increasing the PCH or QPI/Vtt voltages? What other parameters should I be looking at that might help with the video card problems ?

Confusingly, I have read that QPI/Vtt voltage is recommended by Intel to be no higher at 1.21 on the 1156/i5 750 although I see guides suggesting it to be set around 1.35. Could it be I need to have it higher than 1.21 and would it be safe to do so ?

For info, I have PCH at 1.05, and QPI/VTT at 1.8. Ram is set to rated (1333 but at 1.6v).

Cheers
April 3, 2010 11:04:49 AM

Sorry, couldn't edit the last message. There was a typo.

QPI/Vtt is at 1.21, and CPU PLL is at 1.8.

I also have BCLK at 166 with a x20 multiplier, load line calibration is enabled, turbo is disabled and c-states are enabled. Cpu v-core is at 1.25.
a b U Graphics card
April 3, 2010 3:22:50 PM

You might try disabling C-states as well since that is what downclocks your CPU at idle. Could be your CPU is stable at load, but the C-states drop your idle voltages more that the CPU likes? Just an idea.
April 4, 2010 2:30:38 PM

Yeah - thanks for that suggestion. I think you might be right, or at least its contributing to the problem indirectly, but I'm really keen to have all of the green crap enabled as I'm a bit of a hippy. The c-states are enabled at the moment but the display issue is the last problem to overcome before being stable.

I am going to try increasing the voltage on the graphic card. I think the latest drivers I have installed include the fix to keep the card idling at 400 clocks even at the desktop. BUT, I wonder if the voltage drops down when the CPU throttles down or something, causing momentary instability. The GPU voltage is at 1.0 v so I might try bumping it up a little and include that in an overclock on the 5770 itself to see if it helps at all.

One other thing, I can always reproduce the crash in the sensor test in real temp 3.4, when it finishes the cool down test. I think its when the throttling gets right down to 12.5%. Hence, the thought maybe I can keep the voltage up on the GPU.

I'm also going to read up on increasing the PCI-e clocks, and experiment there if it looks worthwhile.

I'll post back if I get stable.
a b U Graphics card
a b K Overclocking
April 4, 2010 2:51:03 PM

flyinfinni said:
You might try disabling C-states as well since that is what downclocks your CPU at idle. Could be your CPU is stable at load, but the C-states drop your idle voltages more that the CPU likes? Just an idea.

This is good advice. I'm running the same cpu. I first o/c with green off, and then went back and worked on enabling all the power saving options. You need more voltage than stock for 20x1.66. The o/c is definitely more unstable with them on, changing states introduces something. If you don't want to add more voltage you should dial it back to 3.2. Yes in turbo mode 1 core gets to 3.2. Your pushing all 4 to 3.2. Dial your o/c back and see if your VGA troubles magically go away.
a b U Graphics card
April 5, 2010 3:50:03 PM

Frenchy- I was meaning it may actually be connected to your CPU overclock. It might be worth just disabling the C-states to see if it helps, and if it fixes the problem, go back and tweak voltages to get C-states stable again. Its worth an attempt.
April 5, 2010 7:03:54 PM

Thanks for the advice guys.

flyinfinni: I was about to go with your idea and turn off c-states but I had already reverted to stock clocks and optimised settings in the motherboard, and then had the grey screen of death on the 5770 with no overclock. And it wasn't even while I was doing the sensor test on Real Temp 3.4 (which usually does it for me) - just surfing and at the desktop.

Maybe it was still the c-states being a pain but perhaps I just have one of the 1001 "standard" problems with the ATI cards. There seem to be as many possible solutions to this problem as there are variations of it - I've got lots of testing. For the sake of posterity, and anyone reading this at some point, I'll report back when I get stable.
a b U Graphics card
April 5, 2010 8:04:55 PM

Yeah- it could be one of the typical 5xxx series problems. Most of those should have been fixed with the 10.3 catalyst update. Did you try using driversweeper and making sure you have a totally clean driver install? might be worth trying one more time. Also might want to check into a BIOS flash to the latest and see if that will take care of it.
July 2, 2010 5:28:20 PM

frenchy - have you ever solved this problem?

I am having the exact same trouble with my 5770 crashing while watch streaming media, but its stable on 3D as long as I don't OC my CPU and GPU too high.
July 2, 2010 7:34:54 PM

below20hz said:
frenchy - have you ever solved this problem?

I am having the exact same trouble with my 5770 crashing while watch streaming media, but its stable on 3D as long as I don't OC my CPU and GPU too high.


Nah - unfortunately not quite.

I thought I had it cracked but it grey screened on me once or twice recently. As I have been moving house (and in temporary accommodation for some weeks) I haven't had a chance to try anything new).

Just hoping it will go away !

!