Sign in with
Sign up | Sign in
Your question

Hard Drive not detected in BIOS

Last response: in Storage
Share
June 11, 2012 6:46:22 AM

Hello all. I've been using this website often while I've been building my computer. Love it!

My motherboard and hard drive are as follows:

ASUS Crosshair IV Formula

Western Digital WD Caviar Green / GP 1.5TB SATA 3 Gb/s

The pc itself has just been assembled. The hard drive simply isn't detected.
The hard drive is used. It was given to me by a friend. I have no idea what is on drive, either. Could existing files on a hard drive keep it from being detected in BIOS? I'm just not quite sure about these things.
Any information will help. I'll be happy to try anything suggested, and I will certainly buy a new drive if this ones toast. Thanks!
June 11, 2012 7:13:46 AM

Try reconnecting the SATA connectors on the dive and mobo, as it could be a loose connection. Try another SATA port on the mobo.
Can you hear the drive operating? If so, is it making any unusual clicking noises. If so, the drive is dead and you need to replace it. If its just no making any noise, then the hdd pcb is at fault, which can be replaced.
m
0
l
a c 103 G Storage
June 11, 2012 3:42:09 PM

Also make sure the SATA ports are all enabled. I ran into a issue like this with an Dell workstation, they disabled all the unused SATA ports as it came from the factory.
m
0
l
June 15, 2012 11:00:13 PM

Thanks for the help. I've tried this hard drive in multiple computers now. No BIOS can even see that there is a device connected. As far as I know, the thing is shot. Also, the jumper is set to factory default, so that's not an issue.
m
0
l
!