Sign in with
Sign up | Sign in
Your question

Automating the hardware acceleration setting

Last response: in Windows XP
Share
Anonymous
January 11, 2005 12:44:45 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

I am running Windows XP on a SunPCi-III board. Due to display glitches
with most Office 2003 products on this hardware platform, each time I start
XP it is necessary to select:

Start->Control Panel->Display->Settings->Advanced->Troubleshoot

and then adjust the Hardware acceleration slider to the 2nd-from-left
position. You then need to click on:

Ok->Ok

to dismiss the menus.

Is there a way to get XP to permanently remember this setting, or failing
that, get this action automated so that it is automatically set each time
XP boots up?

Thanks for any advise you can offer.

Regards,
--
C. Jeffery Small
jeff@cjsa.com
January 11, 2005 3:23:25 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

Yes.

--
All the Best,
Kelly (MS-MVP)

Troubleshooting Windows XP
http://www.kellys-korner-xp.com


"Jeffery Small" <jeff@cjsa.com> wrote in message news:IA4F2L.5q4@cjsa.com...
>I am running Windows XP on a SunPCi-III board. Due to display glitches
> with most Office 2003 products on this hardware platform, each time I
> start
> XP it is necessary to select:
>
> Start->Control Panel->Display->Settings->Advanced->Troubleshoot
>
> and then adjust the Hardware acceleration slider to the 2nd-from-left
> position. You then need to click on:
>
> Ok->Ok
>
> to dismiss the menus.
>
> Is there a way to get XP to permanently remember this setting, or failing
> that, get this action automated so that it is automatically set each time
> XP boots up?
>
> Thanks for any advise you can offer.
>
> Regards,
> --
> C. Jeffery Small
> jeff@cjsa.com
January 11, 2005 5:44:39 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

How?
--
Jeffery Small
Related resources
January 12, 2005 3:18:43 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

First, why does it change? Second, script it and place it in your startup
folder.

--
All the Best,
Kelly (MS-MVP)

Troubleshooting Windows XP
http://www.kellys-korner-xp.com


<jeff@cjsa.com> wrote in message
news:1105483479.006226.246620@z14g2000cwz.googlegroups.com...
> How?
> --
> Jeffery Small
>
Anonymous
January 12, 2005 7:38:38 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

Why not fix it by installing the video drivers to correct the issue?

Jeffery Small wrote:

> I am running Windows XP on a SunPCi-III board. Due to display glitches
> with most Office 2003 products on this hardware platform, each time I start
> XP it is necessary to select:
>
> Start->Control Panel->Display->Settings->Advanced->Troubleshoot
>
> and then adjust the Hardware acceleration slider to the 2nd-from-left
> position. You then need to click on:
>
> Ok->Ok
>
> to dismiss the menus.
>
> Is there a way to get XP to permanently remember this setting, or failing
> that, get this action automated so that it is automatically set each time
> XP boots up?
>
> Thanks for any advise you can offer.
>
> Regards,
> --
> C. Jeffery Small
> jeff@cjsa.com
>
Anonymous
January 14, 2005 12:32:53 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

Bob I wrote:
> Why not fix it by installing the video drivers to correct the issue?

This is on a SunPCi board which is a special Intel board running within
s Sun SPARC workstation. It opens a window on my desktop in which the
Windows XP session runs and translates all IO from/to my workstation
keyboard and the screen desktop running X11. Other than patches
supplied by Sun (all installed) there are no drivers available.

Kelly wrote:
> First, why does it change? Second, script it and place it in your
> startup folder.

It is apparently reset to full acceleration mode upon each reboot of XP.
I would love to script a fix. Unfortunately, all of my experience is
from the UNIX world. If you can point me to some documentation on how
to determine the proper commands buried behind all of these Window XP
menus and where to register the script to get it to execute
automatically (put it in the Startup Folder ??) I would really
appreciate it. Maybe there is something similar on your web site that
you can point me to as an example.

Thank you both for your help.


Regards,
--
C. Jeffery Small
jeff@cjsa.com
Anonymous
January 14, 2005 5:31:10 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

You could try the program "AutoIt" to do something like you want to do.
look it up www.google.com and download a copy.

Jeffery Small wrote:

> Bob I wrote:
>
>> Why not fix it by installing the video drivers to correct the issue?
>
>
> This is on a SunPCi board which is a special Intel board running within
> s Sun SPARC workstation. It opens a window on my desktop in which the
> Windows XP session runs and translates all IO from/to my workstation
> keyboard and the screen desktop running X11. Other than patches
> supplied by Sun (all installed) there are no drivers available.
>
> Kelly wrote:
> > First, why does it change? Second, script it and place it in your
> > startup folder.
>
> It is apparently reset to full acceleration mode upon each reboot of XP.
> I would love to script a fix. Unfortunately, all of my experience is
> from the UNIX world. If you can point me to some documentation on how
> to determine the proper commands buried behind all of these Window XP
> menus and where to register the script to get it to execute
> automatically (put it in the Startup Folder ??) I would really
> appreciate it. Maybe there is something similar on your web site that
> you can point me to as an example.
>
> Thank you both for your help.
>
>
> Regards,
Anonymous
January 17, 2005 3:21:25 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

Bob I wrote:
> You could try the program "AutoIt" to do something like you want to do.
> look it up www.google.com and download a copy.

Bob:

Thank you for the reference. I found the AutoIt site and I will give
the utility a try.

Regards,
--
Jeff
Anonymous
January 19, 2005 11:32:37 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

You're welcome, may you enjoy success.

Jeffery Small wrote:

> Bob I wrote:
>
>> You could try the program "AutoIt" to do something like you want to
>> do. look it up www.google.com and download a copy.
>
>
> Bob:
>
> Thank you for the reference. I found the AutoIt site and I will give
> the utility a try.
>
> Regards,
Anonymous
January 21, 2005 11:44:40 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

In message <IA4F2L.5q4@cjsa.com>, Jeffery Small <jeff@cjsa.com> writes
>I am running Windows XP on a SunPCi-III board. Due to display glitches
>with most Office 2003 products on this hardware platform,

Microsoft even have a support note on this (294916) stating:

"Microsoft Office XP includes drawing code changes that are intended to
support the next-generation GDI replacement, GDI+. Office XP exercises
video drivers in ways that earlier versions of Office do not. Therefore,
problems may be exposed in the drivers that earlier versions of Office
do not expose."

They then have the cheek to state that if the problem persists after
updating to latest video card drivers for you graphics card that

"To resolve this behavior, contact your computer manufacturer for
updated video drivers. If you already upgraded your video card, contact
the video card's manufacturer."

And, on the other hand, they will be screwing those same manufacturers
for their DirectX WHQL Logo.

> each time I start
>XP it is necessary to select:
>
> Start->Control Panel->Display->Settings->Advanced->Troubleshoot
>
>and then adjust the Hardware acceleration slider to the 2nd-from-left
>position. You then need to click on:
>
> Ok->Ok
>
>to dismiss the menus.
>
>Is there a way to get XP to permanently remember this setting,

It *ought* to stay disabled, if that's what you selected in the tab,
because that tab is persistent. If it's reverting there may be a more
fundamental problem with driver installation.

You could try running dxdiag and disable the DX features (in the display
tab).

> or failing
>that, get this action automated so that it is automatically set each time
>XP boots up?

Me too. I do switch between OfficeXP and gaming, so I share your
frustration!

Cheers,
--
Neale Hind
Insanity is hereditary, you get it from your children
!