Sign in with
Sign up | Sign in
Your question

Connecting a monitor to dual GPUs to run in Crossfire.

Last response: in Graphics & Displays
Share
April 4, 2010 10:39:57 PM

Hello,
This is probably a dumb question, but I have dual ATI HD 4800 graphics cards set up to run in Crossfire and I have not been able to get it to work. I realized it's probably because I don't have it connected to my monitor with a dvi cable (duh). I noticed the port on the computer has a dual DVI-I pin setup and the one on the monitor is a dual DVI-D connector. So...that's the cable configuration I want, right? A cable with a DVI-I at one end and a DVI-D at the other? Told you it was a dumb question.
a b C Monitor
April 5, 2010 4:25:10 AM

im not sure what you mean, you have neither card hooked up to the monitor?

in which case, yes you need to have one hooked up. but you do only need ONE card hooked up, if thats what you are saying. you don't need to have both cards connected to the monitor.

as long as both cards are installed in a compatible mobo ,with a crossfire bridge connecting them, the crossfire should activate itself.
m
0
l
April 5, 2010 4:08:05 PM

Im not sure about the connectors on your ATI 4800 - some manufacturers change them. But Crossfire will work with any output on your card, VGA, DVI, Displayport, etc.

So the first thing is to make sure Crossfire is working. First questio is how do you know it isnt working? Benchmarks? Is Crossfire selected on the Crossfire tab of CCC? You can see it come on (for 3d gaming only btw) by right clicking on the ATI tab in your system tray and select Show ATI Crossfire logo.

Second DVI-I will support either analog or digital DVI cables, but not both at the same time. This makes it easy for you. Go get a Dual DVI-D cable and plug it in and you will be good to go. I personally dont like Single DVI-D cables because some monitors are picky about them.
m
0
l
Related resources
April 5, 2010 8:08:03 PM

Bought a DVI-D cable today and will report back.

I know Crossfire hasn't been working because the Catalyst Control Center consistently lists the Secondary GPU as "disabled". MY current setup - recommended over the phone by Velocity Micro, btw - has a DVI-I to VGA adaptor hooked up to the top card and connected to the VGA port on the monitor. I found a manual for Crossfire online that flatly states that Crossfire will only work if connected to monitor that has a DVI port. We'll test that theory later today. Thanks for the help.
m
0
l
a b C Monitor
April 5, 2010 8:16:48 PM

you do have a crossfire bridge connecting the two cards inside your computer right? Also- it is much better to connect DVI to DVI on GPU to Monitor, but I don't think it would actually not work with crossfire.
m
0
l
April 7, 2010 2:30:16 AM

You were right, the cable didn't make any difference. I clicked on the "show Crossfire icon" option in Catalyst and it appears. What I don't understand is why the second adaptor is listed as "Disabled"

Here's my Graphics hardware status according to Catalyst:

Primary Adapter
Graphics Card Manufacturer Powered by ATI
Graphics Chipset ATI Radeon HD 4800 Series
Device ID 9442
Vendor 1002

Subsystem ID 1002
Subsystem Vendor ID 1545

Graphics Bus Capability PCI Express 2.0
Maximum Bus Setting PCI Express 2.0 x16

BIOS Version 011.008.000.000
BIOS Part Number 113-AA48509962.223
BIOS Date 2008/09/16

Memory Size 512 MB
Memory Type GDDR3

Core Clock in MHz 625 MHz
Memory Clock in MHz 993 MHz
Total Memory Bandwidth in GByte/s 63.6 GByte/s


Disabled Adapter
Graphics Card Manufacturer Powered by ATI
Graphics Chipset ATI Radeon HD 4800 Series
Device ID 9442
Vendor 1002

Subsystem ID 1002
Subsystem Vendor ID 1545

Graphics Bus Capability PCI Express 2.0
Maximum Bus Setting PCI Express 2.0 x16

BIOS Version 011.008.000.000
BIOS Part Number 113-AA48509962.223
BIOS Date 2008/09/16

Memory Size 512 MB
Memory Type GDDR3

Core Clock in MHz 625 MHz
Memory Clock in MHz 993 MHz
Total Memory Bandwidth in GByte/s 63.6 GByte/s
m
0
l
a b C Monitor
April 7, 2010 6:12:07 PM

Have you actually run any games to see if crossfire is actually working? Have you tried running something like GPU-z on each GPU to see if they are both actually being loaded when you game? Its possible that it's listing it as disabled meaning that its outputs are disabled, which in the case of crossfire, they would be. I can't say for sure, but I'll try and remember to check when I get home, since I'm running crossfire there as well. Whatever the case, if crossfire is actually performing as it should, it doesn't matter if it lists it as disabled.
m
0
l
April 7, 2010 8:59:35 PM

I've seen other threads where people have had the same issue and seen instances where the second card is listed as "Linked Adaptor" and not "Disabled Adapter" when Crossfire is on. You may be right that it doesn't matter as I've successfully run Quake 4 with the little Crossfire logo showing up and it looks like Crossfire is working. It may just be an issue specific to the game I'm currently playing: Empire Total War. Running that game with Crossfire engaged always leads to system lock up and a hard boot.
m
0
l
a b C Monitor
April 7, 2010 9:06:04 PM

Have you run GPU-z yet to verify that both GPU's are loading during gameplay? that will tell you a whole lot about whether there's a hardware/setup issue or if its more likely just an issue with the particular game.
m
0
l
April 7, 2010 9:07:09 PM

I will try that next. Thanks for the help.
m
0
l
a b C Monitor
April 7, 2010 9:08:54 PM

sure:-) Let me know what it shows!
m
0
l
April 14, 2010 12:06:37 AM

It looks like it's just an issue with the game Empire Total War.

I may have to upgrade to a 1GB GPU instead of running the two 512 cards in Crossfire.

Thanks for helping me figure this out!

m
0
l
!