Sign in with
Sign up | Sign in
Your question

Metro 2033 Radeon 5850 + NVidia 8800GTS 512MB dedicated PhysX Card

Last response: in Graphics & Displays
Share
April 5, 2010 2:27:02 AM

I everyone. I recently bought Metro 2033 and cant get hardware PhysX to run with my dedicated card alongside the Radeon 5850. Im using Windows 7 64 bit, and I have been using the PhysX mod (caked) 1.02, but the Steam PhysX update always invalidates my attempts. I have got the PhysX to appear turned on for the 8800 GTS in GPUz, but as soon as I run Metro, even if I launch it from the steamapps/common DIR via the executable the update seems to invalidate the PhysX capability. Fluidmark would use hardware up to the pointof the update. Has anyone got a link to the fabled PhysX mod 1.04 or a version which is compatibly with the new NVidia 197.## Geforce drivers? Or any suggestions?
a b U Graphics card
April 5, 2010 2:29:49 AM

Do you have Steam in Offline mode, or does it update before you can do that?
April 5, 2010 2:30:37 AM

Good idea I'll try that. Watch this space.
Related resources
April 5, 2010 2:33:36 AM

EXT64 said:
Do you have Steam in Offline mode, or does it update before you can do that?


WTF!!?!!? Its working now. The PhysX options werent appearing in the NVidia Control Center but they are now (?!) Just went out had a couple of beers, came home, booted and now its working. Ive been trying to do this all day. LOL!
Fluidmark just showed hardware, and drivers are 197.##.

Two word. Ball-ache.
a b U Graphics card
April 5, 2010 2:38:44 AM

So, does the game seem to work now too?
April 5, 2010 3:16:07 AM

EXT64 said:
So, does the game seem to work now too?


Yeah its working great! With my 5850 running @ 850/1200 im running maxed out (wih the exception of AF which is at 4x) at 1920x1080 now with Hrdware PhysX on and its a good playable speed. Bizarre though, I didnt even need to uninstal/re-install the old drivers and put Steam in offline mode. I just gave it one last try and it worked. lol.
a b U Graphics card
April 5, 2010 3:26:21 AM

Well, glad it started working. Software really doesn't make sense some(most) times.
!