Sign in with
Sign up | Sign in
Your question

Out of ideas plz help

Last response: in Storage
Share
June 15, 2012 8:35:42 AM

Okay so I bought an Asus DRW 24-B1ST CD/DVD Burner from newegg and it arrived today via UPS. I threw in the drive, connected it properly and got it running right off the bat with no problems. Then I tried updating the firmware and ran into my first issue. Every time I go to update it I get an error message that reads:

'No matched drive detected ! This utility is only for ASUS DRW-24B1ST drive. Detected drives: 0-1-0-0 D:ASUS DRW-24B1ST C 1.05'

After multiple forum and Google searches I came across several ways to resolve the issue, but had no luck. Some of the solutions I tried were the fixit solution and the regedit solution. Fixit did nothing and when I tried the regedit solution, I couldn't find the upper or lower filters anywhere in the specified area. I gave up on the firmware since I burnt a data disk (American Dad - Season 6) prior to any of this B.S.

The issue I'm having is burning .iso files. The main reason I bought this drive was to burn the .iso files I had to a disk (i.e. Ubuntu) so I wouldn't have to use my room mates laptop to do so. I've used at least 10 different programs, all dedicated to burning iso files and all I get after the burns are complete are coasters. I've thrown at least 12 dvd-r discs away already. I read somewhere about lowering the write speed, but still the same results.

At this point I have no idea what's going on and I've given up all hopes for this new drive seeing as it can't do the main thing I bought it for. It reads, it writes data but cannot burn an iso?

Any help would be greatly appreciated seeing as how all my attempts have failed. If it makes any difference, I'm running windows 7 64 bit

More about : ideas plz

a c 277 Ĉ ASUS
a c 189 G Storage
June 15, 2012 1:43:29 PM

Have you tried imgburn?
m
0
l
a c 277 Ĉ ASUS
a c 189 G Storage
June 15, 2012 1:44:14 PM

Only update the firmware if you are having issues with it.
m
0
l
Related resources
a b G Storage
June 15, 2012 2:09:15 PM

I've had good luck with CDBurnerXP.It has a .ISO burn feature. and it's free!
Just google it.
m
0
l
June 15, 2012 7:00:06 PM

Thanks for the suggestions guys, but I know at this point it's not the software I'm using to burn the files with, it's something with the drive itself. I tried using both of those programs and still the same results. The software verifies the disk after the burn and says that it's successful, but when I open My Computer and click on the D: drive, it's just a blank space that says 'Drag Files To This Folder To Add Them To The Disk'.

I only spent $16 ($19 after shipping) so it's probably not worth returning seeing as how I'd end up paying to do that too. It just sucks because I usually have good luck with newegg and haven't received a buggy or faulty product from them and they're my go-to guys when it comes to hardware.

I don't doubt that a solution exists and I still have hopes that one day it'll be figured out. For now, though, I have a drive that at least reads and writes much faster than my old one so I guess that's a plus...just can't use it for what I bought it for in the first place.

Thanks again guys.
m
0
l
a c 118 Ĉ ASUS
a c 127 G Storage
June 15, 2012 7:44:47 PM

i would email asus support...the drive is a rebraded litton drive..the firmware on there web page is for the b rev not the new c rev drive.
m
0
l
June 15, 2012 7:54:31 PM

if you put one of the burnt disks in your mates laptop does that show the disk as used or unused. If it sees a blank disc can it still be written to by the Laptop?
m
0
l
!