Unable to ntfs format flash drive

Hello,
i have purchased two 32 gig flash drives over web and cannot format either one as ntfs. i tried all the usual tricks like optimise, command line format, just got error message that computer could not format drive. Fat format is ok, and even tried that first before trying ntfs again. Is this just an issue with cheap flash drives? (the chip failed first several qc tests?) Thank you for any help.
6 answers Last reply
More about unable ntfs format flash drive
  1. ... why would you want to format a flash drive as ntfs?
  2. ^Agreed. I use FAT32 with mine.
  3. It would be nice to write 4GB+ files to that drive. FAT only goes up to 4GB.

    I'm not sure here, do they say anything about supporting NTFS?
  4. True... it would help for 4+GB files I suppose

    Try this: http://www.ntfs.com/quest22.htm
  5. The question was not why i would want to but why i cannot. NTFS is needed for incryption of files larger than 4 gig which is important if you carry around your flash drives. But i have purchased two 32 gig flash drives that failed ntfs format. I suspect that companies are using chips that are defective to make these drives, chips that are ok for fat32 but not ntfs. I am am just interested in any comments about this, and how can you know if a flash drive will format ntfs before you buy it?
    Thanks.
  6. The reasoning is that FAT 32 is compatible for all OS (linux, mac, windows). You should be able to format it to NTFS, I don't see a reason why it shouldn't work.

    You can try this method: It's simple
    http://www.howtogeek.com/58953/how-to-convert-a-hard-drive-or-flash-drive-from-fat32-to-ntfs-format/
Ask a new question

Read More

Flash Media NTFS Format Storage