Sign in with
Sign up | Sign in
Your question

Reboots hang for over a minute. Research Help.

Last response: in Motherboards
Share
January 19, 2011 3:47:02 AM

I've been here once before with this motherboard/BIOS issue, and it was partially solved by a fine member here.

My system, before his suggestion, would hang on restarts causing me to ALWAYS turn the computer off in order to start the computer into Window 7 x64.

His suggestion, to disable the legacy floppy, did work as the computer did eventually restart.



Now, however, I've grown tired of the wait to boot back into Windows 7 (over a minute). I've since wiped my computer and carefully attempted to see what caused the the rebooting 'issue'. It seems that when I plugged in my USB 2.0 WD 1.5 TB External Drive ("My Book Essential" is the drive's name), suddenly that is when the painful hanging issue started.

I have done some searching on External Drive reboots, and have seen some possible solutions to fix it; yet nothing ever does. I've 'disabled' USB Legacy Mode, which many have said fix the issue. Nada here. Someone at Western Digital said: "The BIOS is seeing the external drive as a possible boot drive, and is stuck looking for the boot sector". That I could see, as it is listed as a Hard Drive in the BIOS. Is there a way to get it out of that list while keeping the drive connected to the computer? One person also mentioned that I should plug it into a Hub. No idea why, but I'm willing to try if some think it might fix this annoying situation. But I've seen a note from another WD Tech another tech that said NOT to connect it to a hub or the system will halt even worse.

Another: "The SES driver in the BIOS is preventing the computer from starting up because it's trying to read the external drive as a SCSI enclosure" (HUH??...Greek to me)...but basically I'm supposed to 'disable' this SES driver which I've come to understand means my onboard sound. But that's the only sound I get from this machine.

So frustrating. If any one has a suggestion (I might understand...AND...might seem doable; unlike killing my sound) I'd REEEEALLY appreciate your input. I'm beyond pulling my hair out with this.


Thanks so much!

Bruce

ASUS P5N-D mobo
Q6600 Intel core 2 Quad 2.4MHz
Win7 x64
4GB DDR2 667
January 19, 2011 3:09:06 PM

Slow boots with a "mass storage device" plugged into usb are all how the bios deals with them...

I had an old (2003) board that took about 45 seconds to detect each device. New board boots fine with the same devices connected.

Do you have the latest bios for your board?
a b V Motherboard
January 19, 2011 3:19:28 PM

riff99 said:
Someone at Western Digital said: "The BIOS is seeing the external drive as a possible boot drive, and is stuck looking for the boot sector". That I could see, as it is listed as a Hard Drive in the BIOS. Is there a way to get it out of that list while keeping the drive connected to the computer?
Yes, the WD external drive can be removed from the boot list. Just go into the BIOS to the "BOOT" menu and set the boot order so the first hard drive the system attempts to boot into the OS from is your main OS drive. You may also want to check the "HARD DISK DRIVES" menu and verify that the WD External drive is not the 1st disk drive but the disk drive with the OS installed on it is the 1st disk drive.

riff99 said:
Another: "The SES driver in the BIOS is preventing the computer from starting up because it's trying to read the external drive as a SCSI enclosure" (HUH??...Greek to me)...but basically I'm supposed to 'disable' this SES driver which I've come to understand means my onboard sound. But that's the only sound I get from this machine.
The SES drive is not related to the sound, it has to do with the driver associated with the WD external drive. To update or disable the ses driver, it would be done through the Device Manager. Most likely the driver needs to be updated, in which case try the following;
. Right Click on My Computer/Computer, Select Manage.
. On the New Screen, select Device Manager and then look on the WD SES drivers with yellow mark,
. Then Right Click on it, and select Update drivers.
. Now select WD Smartware and then select WD SES drivers under Extras.

Not sure f updating the ses drivers has anything to do with the issue, but won't hurt anything either, so...

Of course, when all else fails, try plugging the external drive into a different USB port to see if you get the same result.
Related resources
January 19, 2011 4:31:45 PM

Thank you both for your replies...

Firstly, yes, the BIOS has been updated to its latest version. (14.01 - Jun/10)

All previous reboots from the OS were just seconds long before the External Drive install. I just figure there's GOT to be a way to make this somewhat faster (heck, 45 seconds seems quick compared to this).

Also, when I am in the BIOS BOOT Management section under Hard Drives, it shows my two SATA drives and the External Drive (just says "My Book") in the listing. I have a 400GB SATA, that has my OS on it (C Drive) currently as #1, 320GB SATA (D Drive) as #2, and the My Book External Drive as #3 (weird thing is that it almost appears grayed out; definitely a lighter type face than the other two drives). That why I'm thinking/hoping that there might be a way to hide it from the listing. Yet still found by the OS...

I haven't touched re-loading the SES driver ever since I read I had to disable it anyways. (since reloading the OS). I just figured that since I read so much about SES and how it was 'supposed' to coincide with the onboard sound BIOS 'disabling', that I'd leave that item alone. When I purchased this drive, all I wanted was to backup all my files to it. I don't really care about it's SmartWare software (with SES driver) which automatically backs up these files for me. I guess that once that was completed before the formatting, I should just disconnect it until I need it again. Kind of sad because like a lot of hardware we have attached to our computers (ie. printers, webcams), we can keep those attached at all times until we need those. Yet External Drives seem to have their own set of rules in this equation according to the BIOS. Would be nice to keep it connected, but not if it continues to slow things down I guess.

Frustrating...

Any chance of 'enabling' S.M.A.R.T. as a way of helping with out the BIOS Boot issue? Doubt it, but looking for anything. Also, I cannot find any where in the BIOS about "BOOTing from a USB device". Some say it's in their BIOS options, but nothing in mine.
a b V Motherboard
January 19, 2011 8:57:21 PM

riff99 said:
Also, when I am in the BIOS BOOT Management section under Hard Drives, it shows my two SATA drives and the External Drive (just says "My Book") in the listing. I have a 400GB SATA, that has my OS on it (C Drive) currently as #1, 320GB SATA (D Drive) as #2, and the My Book External Drive as #3 (weird thing is that it almost appears grayed out; definitely a lighter type face than the other two drives). That why I'm thinking/hoping that there might be a way to hide it from the listing. Yet still found by the OS...
The fact that the BIOS shows the WD external as "greyed" out is a good thing in that the BIOS recognizes that it is not a bootable drive or does not have a MBR; no reason to "hide it" from the BIOS. Checking to determine where it stood in the boot order was to ensure that the WD drive was not being seen as a bootable device and possibly causing a slow POST and boot process.

It seems to me that the "hanging" is due to Windows detecting the USB drive and initializing it. There may not be much else that can be done to increase the boot time other than tweaking the boot config or unplugging/plugging in the WD drive when you need it. Don't forget to install the latest chipset drivers and apply any Windows updates to eliminate that as a possible slow down.
!