Sign in with
Sign up | Sign in
Your question

Gigabyte 890FXA-UD5 Digital Optical Port Not working

Last response: in Motherboards
Share
January 21, 2011 12:16:12 PM

This problem is driving me nuts!

The above board has both Coax and Optical Digital Out on the Rear Panel. When I switch the Optical out device to Default, the Playback mixer indicates that sound is being played but I get nothing on my Digital amp. The coax port works just fine. On checking the Optical device properties the output is wired to "Internal ATAPI device" which is obviously wrong - it should be "Back Panel port"or similar sounding name. This is obviously causing the issue but I cannot find any way of mapping the port correctly in the Reaaltek HD Manager.

Gigabyte don't seem interested in helping.....anyone got any ideas or experience of this issue?
a b V Motherboard
January 21, 2011 4:50:46 PM

Go into Realtek HD Audio Manager. You'll see Digital Output (optical) tab. You will see your optical connection on the lower right hand side. Click on it to configure. You may need to set it as default device. All can be done within this manager.
January 21, 2011 9:09:24 PM

jockey said:
Go into Realtek HD Audio Manager. You'll see Digital Output (optical) tab. You will see your optical connection on the lower right hand side. Click on it to configure. You may need to set it as default device. All can be done within this manager.



Setting it as the default device makes no difference. I can see nothing in the Realtek Manager which allows you to map the Digital ports to the physical Jacks on the Board. This whole thing is ridiculous - anyone buying a board requiring an Optical out port for their Digital amp is basically screwed. Besides which an Optical Input port does not even exist on the main board internally anyway. This board goes back pronto!
Related resources
a b V Motherboard
January 21, 2011 10:47:15 PM

Here's a manual for your board in pdf.
http://download.gigabyte.us/FileList/Manual/mb_manual_g...
It's the same as the booklet, but easier to read.
The audio manager starts on page 102, your info is on page 105. Hope this helps.
Yes, that mobo does have internal ports for in and out on it, to use on an expansion card.
January 22, 2011 8:09:40 AM

jockey said:
Here's a manual for your board in pdf.
http://download.gigabyte.us/FileList/Manual/mb_manual_g...
It's the same as the booklet, but easier to read.
The audio manager starts on page 102, your info is on page 105. Hope this helps.
Yes, that mobo does have internal ports for in and out on it, to use on an expansion card.


Thanks, I had the manual and read all this. Nowhere on the HD Manager does it allow you to map the ports. I have given up with Gigabyte support so it looks like an RMA and I won't be touching their products again.
a b V Motherboard
January 22, 2011 8:22:39 AM

Try selecting spdif or optical in your playback application. Or get AC3Filter and select optical in the filters.
January 23, 2011 10:36:59 AM

mosox said:
Try selecting spdif or optical in your playback application. Or get AC3Filter and select optical in the filters.


Its not the Digital Device selection that's the problem - i have tried all the usual device selections and tests - with the Optical out set as default the Volume display clearly shows sound is being played to the port - but its the Internal ATAPI port which is no use to me without me buying an extra rear port adapter. The driver is clearly assigning the Optical out signal to the Internal port and the existing Optical port on the rear panel is left unassigned.(the one I want to attach an Optical cable to and use my Digital amp). I need a fix where the jack assignment is either corrected (with the existing Rear panel optical Jack assigned to Optical out) or gives the user the ability to do the assignment manually. I'm buggered if i'm going to spend money on another port adapter to get round this ridiculous setup :fou: 
September 30, 2011 4:17:37 AM

fixit4me said:
Its not the Digital Device selection that's the problem - i have tried all the usual device selections and tests - with the Optical out set as default the Volume display clearly shows sound is being played to the port - but its the Internal ATAPI port which is no use to me without me buying an extra rear port adapter. The driver is clearly assigning the Optical out signal to the Internal port and the existing Optical port on the rear panel is left unassigned.(the one I want to attach an Optical cable to and use my Digital amp). I need a fix where the jack assignment is either corrected (with the existing Rear panel optical Jack assigned to Optical out) or gives the user the ability to do the assignment manually. I'm buggered if i'm going to spend money on another port adapter to get round this ridiculous setup :fou: 


I'm having the same issues but it is the Digital RCA/Coax audio output that is trying to map to the Internal ATAPI port and my RCA output port is mapped to the Realtek Digital Input. Have you found any solution to this problem (Windows registry keys, mobo switches)?
October 3, 2011 3:13:26 PM

kre0380 said:
I'm having the same issues but it is the Digital RCA/Coax audio output that is trying to map to the Internal ATAPI port and my RCA output port is mapped to the Realtek Digital Input. Have you found any solution to this problem (Windows registry keys, mobo switches)?

Same problem here. Has anyone figured this out? When I mouse over the coax icon in the audio manager it shows it as being an optical out...
I have a RCA jack wired up to the pins on the board and running out the back of the pc for sound now as a temp fix.
October 22, 2011 4:18:08 PM

black6 said:
Same problem here. Has anyone figured this out? When I mouse over the coax icon in the audio manager it shows it as being an optical out...
I have a RCA jack wired up to the pins on the board and running out the back of the pc for sound now as a temp fix.


Simple fix someone pointed out to me on another board - just select Realtek Digital Output (Optical) as your default output device. It sends the signal to both optical and RCA at the same time when that is selected.
December 17, 2011 5:13:34 PM

kre0380 said:
Simple fix someone pointed out to me on another board - just select Realtek Digital Output (Optical) as your default output device. It sends the signal to both optical and RCA at the same time when that is selected.


Setting default isn't necessary per se. But the above is correct, SPDIF is output on both optical and coax when the optical is selected.

The 'optical' config controls the 'coax' config as well. There is no unique control of the 'coax' spdif.
!