Sign in with
Sign up | Sign in
Your question

2nd HDD is IDE and won't boot

Last response: in Storage
Share
June 20, 2012 5:41:17 AM

Hello

So...I'm trying to recover data from my newer, Corrupted, hard drive.

My plan was to take an older HD and attach it to my newer computer via IDE cables
...then boot that HD up, running window xp, and use a program called "Recuva" to
access my corrupted HD and pull the family pictures and other files off it and onto
my IDE HD.

Newer, Corrupted HDD

Windows Vista Home Premium 64 bit SP1
750 Gb HD
Hitachi
connects Via SATA 3.0

Older HDD

Windows XP home SP2
60 Gb HD
Western Digital
conntects Via IDE

The OS of my IDE HD, windows xp, was not installed while plugged into the computer I'm trying to fix...it was
installed on my older computer and then the HD was removed and attached to my newer computer Via
IDE cables

When I boot up my newer computer and tell it to boot from the IDE HD, which it does recognize, it will
take me to the Safe Mode menu...and whether I try to start in Safe Mode or tell it to start Normally it
will always just reboot and just keeps running me through the same cycle again and again....so...I
am unable to get my IDE HD to boot up Windows XP on my newer computer.

Some internet articles are saying that I can't just do that...that in order for my newer computer to recgonize
my IDE HD I have to install my OS while plugged into my newer computer...something about needing
drivers from the installation of the OS

Do I really need to re-install my Windows XP onto my older HD while plugged into my newer computer
and if so...do I leave my corrupted HD still plugged in Via the SATA cable or do I need to disconnect it
so that I don't accidentally install XP onto the corrupted HD...which I assume will erase all the data I'm
trying to recover

Also.................

I have tried a bootable cd with a program called Photorec on it and I could not get it to work
...it would run like it was pulling pictures off my corrupted hd and putting them onto my
external HD and then it would just stop and say there was no more space left...which is
impossible since there was over a Terra bite of space that it couldn't possibly fill

...and the files it claimed to recover in folders called "recup" were never found on my external
HD and the size of my external HD never grew or shrunk so where those "recup" folders went
to is anyones guess

More about : 2nd hdd ide boot

a c 329 G Storage
June 21, 2012 2:51:17 AM

First, I do recommend that you disconnect your newer corrupted HDD while you work on getting the system working using the older IDE drive. AFTER it is working, you can reconnect the newer SATA unit and work on that.

Next, it is normal that you can't boot as you are trying. The drivers installed on that older IDE unit are the ones for the machine it came out of, and it does not contain drivers for the new machine. Certainly a complete wipe out and re-Install of Win XP on that drive would solve this. HOWEVER, there is a less drastic step that might work for you.

You need a Win XP Install CD - preferably the one used on that IDE drive before, but another will probably do. Set up to boot from your optical drive and start as if you were going to install Win XP on the IDE drive, BUT DON'T DO THAT! Look on the initial menus for an option for a REPAIR INSTALL, and do that. This process takes a survey of all the devices in your machine and compares that to the drives already installed on the HDD, the tries to fix all the mis-matches. When done, you reboot the machine without the CD in the optical drive. If it all worked, your Win XP on the old IDE drive will have been updated to work with the hardware in the new machine.

Be aware, however, that this IDE drive's updated version of Win XP will no longer work in the old machine it came from - the drivers have been changed!
!