Sign in with
Sign up | Sign in
Your question

Windows 7 Winsock reg missing

Last response: in Networking
Share
February 23, 2010 3:47:34 AM

So, I'm not quite sure what the hell happened to my computer, but due to a fun combination of a failed in mid-install firewall and my attempts to remove the last vestiges of it (zonealarm), it seems that the winsock entries in the registry have completely disappeared (which i figured out after some internet searching of my lack of internet connectivity issue). I've tried the basic fixes of 'netsh winsock reset' in cmd, which gives me the message of 'file not found,' I've also tried looking for any winsock fixes for windows 7 64 bit, but so far am not having any luck. Would anyone have any idea how to completely restore winsock and any other necessary related files to fix my internet connection? I'm trying to avoid a clean re-install but so far haven't had any luck with anything... thanks in advance!
February 23, 2010 4:04:44 AM

Is this your own build or a prebuilt desktop? When I have a problem like this I just grab the Windows 7 install disk and do a repair install. Of course, if it's a prebuilt, that may not be possible (or at least quite as easy).
m
0
l
Related resources
!