Sign in with
Sign up | Sign in
Your question

ISA conflict on P4 MB

Last response: in Motherboards
Share
January 22, 2011 2:12:31 AM

Hello, I am new here, but I have used this site for 9 years for info. Anyways, Here is the issue. Right now, I have a CNC Mill, with a P1 MB, and the controller card for the machine is ISA, plus it runs on DOS. I have DOS 7.1 installed right now, and it works fine. When I installed the P4 board, the led lights come on, on the control card, and the computer is sending the code to it, but will not connect with the card. I am trying to figure out if it is an IRQ conflict, or what maybe causing this. One other thing, it has a PCI VGA card. I pulled the AGP card from another computer, to try that, but not sure if it will work. Does anyone know anything about ISA slots with a P4 MB?

More about : isa conflict

January 22, 2011 5:25:51 PM

Well, I bought a PIII MB today, but I would still like to see if I can get my P4 board working with my SCSI ISA Control Card. Any help or ideas?
m
0
l
January 22, 2011 5:36:26 PM

I am not aware of any P4 MBs having ISA slots, can you post a picture of the motherboard in question along with the manufacturer and model?

You will also need to find out what memory address your ISA SCSI card is set to and compare it to the onboard devices on your MB and the address space they are using and ensure their are no conflicts. ISA is not exactly Plug and Play. We used to call it Plug and Pray for a reason :) 

It also may be easier to get a PCI scsi card and move your drives to the new controller card.
m
0
l
Related resources
January 22, 2011 5:46:02 PM

I wish I could go to a PCI Card, but ISA is the only thing that they make, at least for this machine. The MB I have is an Intel P845WR, and I bought it out of Canada, and bought another out of China. They still make P4 MBs with ISA slots, due to alot of equipment runs on ISA stuff. The MB I am trying to use, the Intel, is a M ATX, which does not matter, but it fits right in the machine. I had to make a new Panel to mount it. The Company that sells parts for this machine, sells a PIII MB for 1K, and I am not paying that much for one. I have already upgraded the HDD to SSD, due to the disk style gets wiped out after a few months, and then I got a SATA SSD with and EIDE adapter, so I could get a bigger SSD for a good price. The whole reason I am trying to upgrade, is to dual boot with DOS, and Win98SE, so I can load programs with a thumb drive instead of running a cat 5 cable from my house to the shop. I would have to put a computer or some type of signal booster to get it to the shop.
m
0
l
January 23, 2011 11:57:18 AM

Ok, reinstalled the P4 MB into my machine last night. Got into the BIOS to see if there was a setting I missed. I did find a setting the was disabled for IRQ 10, which it says was for legacy/ISA, so I enabled that. Still would not access my control card. I tried to set the IRQ settings for the PCI slots, and asign them an IRQ instead of leaving them on auto. Nothing, seems to work. I stuck my AGP Video card on the board, and it did not change anything. I also tried to enable the DMA addresses, or I think that is what they were, been along time. Still nothing. I have nothing installed into the PCI slots, due to not wanting any interferance with the ISA slot. I am not sure if I should try reloading the OS back in, but I am about to give up on this. I did buy a PIII board, because the guys on the machineing forum told me that it is the only thing that will work, and the P4 chipset does not support ISA, even though there is alot of companies making P4 MBs with ISA slots. Please help!!!!
m
0
l
June 2, 2011 2:54:14 AM

Not sure if this is still an issue, but I have just found out that the newer power supplies do not have a -5v wire anymore, so even if you have an isa slot, you may not have power to it. Check the 24 pin motherboard connection for the white wire in slot 19
m
0
l
!