Computer Loads Up, But No Video for Windows

OK I built a new computer, has an ATI Radeon 5850 as GPU. I got everything installed using the onboard video card but when I installed the Radeon, I can view to BIOS startup but as soon as it loads Windows 7 it goes blank, it tells me its running in 1920x1080 but its just black. Anyone had this problem and found a way to fix it? Also the onboard video doesn't work when the card is in.

Much Appreciated
6 answers Last reply
More about computer loads video windows
  1. demowiz said:
    OK I built a new computer, has an ATI Radeon 5850 as GPU. I got everything installed using the onboard video card but when I installed the Radeon, I can view to BIOS startup but as soon as it loads Windows 7 it goes blank, it tells me its running in 1920x1080 but its just black. Anyone had this problem and found a way to fix it? Also the onboard video doesn't work when the card is in.

    Much Appreciated



    when you boot, go into the bios, and select onboard or video card

    are you sure your video card supports 1920 x 1080, and monitor
    if you have 2 monitor connections on your video card, try the other

    boot in safe mood , uninstall video card in the device manager, reboot
    also , if you can boot into safe mode,probably driver problem
  2. yeah cant boot into safe mode but was able to disconnect the Radeon 5850 and get a screen with the on board video. Trying to install drivers for the Radeon to see if that helps.
  3. okay..if you got the onboard to work..make sure you change your bios settings when you want to use the video card, make sure your onboard video card is disabled....some motherboards will have a setting for auto too.. you have narrowed it down to your video card or that bios setting....also , take video card out and reseat it.
  4. Yeah I had to take out the video card in order to get it running with onboard. Put the card back in, it gets to windows loading screen now and then goes blank. Alittle progress.
  5. Figured it out, its the crappy no name HDTV I got, works fine on my 52" samsung. So looks like a new monitor is in order.
  6. cool........glad you got your rig working--- :D
Ask a new question

Read More

Homebuilt Computer Radeon Systems