Sign in with
Sign up | Sign in
Your question
Solved

AHCI Mode help

Last response: in Storage
Share
June 22, 2012 5:47:07 PM

I just recently installed Windows 7 Professional 64bit. And i heard that AHCI mode increases hard drive performance. I tried the registry trick, changed the mode from Raid to AHCI and i got a BSOD on startup and changed it back to raid. I'm clueless on what i did wrong is it perhaps a driver issue ?

*In device manager, my storage controller is "Intel(R) ICH8R/ICH9R/ICH10R/DO SATA RAID Controller"

Edit: correct me if i'm wrong in RAID mode doesn't it already enable AHCI by default. and only in IDE mode
AHCI isn't enable. (i'm in RAID mode and only using one harddrive. I installed windows 7 with two harddrives)

More about : ahci mode

a b $ Windows 7
a b G Storage
June 22, 2012 5:57:12 PM

You should do the registry trick restart the computer and then go into the BIOS and change the BIOS SATA mode from IDE to AHCI.
m
0
l
June 22, 2012 6:30:27 PM

Well i've already done that and i still got a BSOD. is there any drivers i need to install beforehand and if this changes anything windows installed in raid mode
m
0
l
Related resources

Best solution

a b $ Windows 7
a b G Storage
June 22, 2012 11:55:29 PM

Windows 7 should have the SATA driver for your motherboard built in, it is rare to find a motherboard where you have to supply the SATA driver. You could try a repair install but make sure you back up your data first. To be honest you don't notice much difference between IDE and AHCI mode with a hard drive it is only with SSD that it makes a big difference.
Share
June 23, 2012 1:19:27 AM

Best answer selected by anything_.
m
0
l
June 23, 2012 1:45:12 AM

The driver you need will be installed when you reboot your machine,after you've done the registry hack and select ahci in the bios
m
0
l
!