Sign in with
Sign up | Sign in
Your question
Closed

I am trying to use ATI 5970 and GTX 280 for Physx but without success

Last response: in Graphics & Displays
Share
April 10, 2010 7:09:03 PM


I have an MSI neo2 fr mainboard in which (in the primary PCIe slot) there is an ATI 5970 installed. In the secondary PCIe slot, a GTX 280 is installed.

I want to use the GTX 280 for Physx only!

The problem I am now facing is that the GTX 280 is set by the BIOS as the primary GPU even though it is in fact installed in the secondary PCIe slot.

I have two screens , one is hooked to the ATI 5970 and the other to the GTX 280. The BIOS shows up on the screen connected to the GTX 280 and defines this card as the primary GPU.

In Windows 7 the ATI card (and the screen connected to it) is recognized as secondary. Therefore changing this screen to be the primary screen in Windows does not fix the problem.

I think I have narrowed down the problem to the BIOS not having an option to manually switch PCIe slots. All that can be switched is between PCI and PCIe and this basically is ineffective to solve the problem. In addition switching the cards themselves within the slots doesn't work either.

Since there is no newer BIOS version, is there any way to hack the BIOS or the mainboard to enable the ATI card to be the primary card ???
April 10, 2010 9:30:19 PM

look it's not that simple.
first:
download and Install nvidia 196.34 beta firmware (it MUST be this version) then the physx 9.10.0222 driver (the reason i give these driver version is that only they seem to work correctly for now so if you want to upgrade drivers first see if they're compatible.)

second:
download hybrid Physx mod 1.02 then run it on safe mode.(it's interface is a bit strange.to run it click on cake.)

Third and last:
necessary step and solves your problem. you use ati for both monitors then go to screen resolution and click on detect then another monitor must appear.
1.for display select nvidia gpu.
2.and for multiple displays set it on try to connect anyway on:VGA
(actually in this way you'll connect your GPU to a virtual CRT monitor.but since you can't make your nvidia gpu secondary it will fix this way.) [:mohsentux:7]


Tell us if it worked.
Related resources
April 10, 2010 9:53:33 PM

Woah, Nice power supply :) 

(If it can handle a single GTX 280, nevermid one and a 5970)
a b U Graphics card
April 11, 2010 3:01:39 AM

An 850W power supply can handle 2x5970

April 11, 2010 5:32:21 PM

Thanks. I have already tried this but it does not help. I have already used Physx-mod-1.02 before and enabled Physx.
Physx seems to work in some games only but not in others.

For example Just Cause 2 does not start at all if both cards are installed. It will only start if one of the cards is disabled or removed.

Another example is Heaven Benchmark v2.0 which will only run in the resolution of the screen of the GTX card no matter if a screen is connected or not or whatever setting is put in it.

It seems that some games can internally in themselves switch between the two cards and select the ATI card:
for example 3DMark Vantage works fine and seems to be using both cards. This can be seen in the result where the ATI card alone has about 12,400 and both cards have about 13,800

I do not think that the problem can be fixed in Windows since the BIOS dictates which of the two cards is the primary one.

Therefore switching screens in Windows does not help. I think what is needed is a BIOS or mainboard hack to dictate that the ATI card is the primary one. Any ideas how this may be achieved ????

PS: I have a Thermaltake Toughpower 1000W power supply.
April 17, 2010 10:38:55 PM

Unfortunately it can't be achieved at all. Just Cause 2 had some of its graphics designed by Nvidia people.

I've tried doing the same thing, and to make a long story short, it doesn't work. It isn't a hardware issue, so messing with the bios isn't going to help at all. I know, it makes me sad too :( . I don't know why Nvidia has such a hard-on for people using their cards as an auxiliary. I suppose they make money through the sales of new cards, not old ones, so they're trying to protect their business. That's still shady business though.

The game was designed to put all of the processing on the Nvidia card if one is detected and being used at all. The only thing that could possibly change that would be a mod. I don't know if the community would be up for farting around with that.
a b U Graphics card
April 17, 2010 11:02:52 PM

Wasn't there something about the only way you could use an ATi card and nvidia card for physx was to use older nvidia drivers?

Nvidia then changed it so that if there is an ATi card installed, physx wouldn't work or something like that.

I might be wrong, but that is what I think.
a c 125 U Graphics card
June 10, 2010 5:44:28 PM

This should work fine. I have crossfire 5850s with a GT240 as PhysX. Got it working in 10 minutes. I followed this guide:
http://forums.overclockersclub.com/?showtopic=174041

You can see if it's working by running FluildMark and MSI Afterburner will show activity on it. I will admit tho I've only tested with FluidMark and Metro 2033. I have yet to try some other PhysX games. I definitely want to give Batman: AA a try (beat it on PS3 but it's worth another playthrough :D )
a c 272 U Graphics card
June 10, 2010 11:52:19 PM

wolfram23 said:
This should work fine. I have crossfire 5850s with a GT240 as PhysX. Got it working in 10 minutes. I followed this guide:
http://forums.overclockersclub.com/?showtopic=174041

You can see if it's working by running FluildMark and MSI Afterburner will show activity on it. I will admit tho I've only tested with FluidMark and Metro 2033. I have yet to try some other PhysX games. I definitely want to give Batman: AA a try (beat it on PS3 but it's worth another playthrough :D )

Considering that you pulled up a two month old thread, you could at least have mentioned that the 257.15 beta driver did not have that restriction in the earlier versions so if you can find one then you will not have to bother with hacked drivers, spoofed VGA ports or be stuck with an old PhysX driver version, as that gets an update too.
!