Sign in with
Sign up | Sign in
Your question
Solved

Iomega prestige 1tb forums

Last response: in Storage
Share
June 23, 2012 8:44:53 PM

I've been using an Iomega Prestige 1T external hard drive with my Macbook (OS 10.7.4) for a while with no problem. Today I was uploading data to the drive when I suddenly got the "this device was not ejected properly" message. Now the drive won't mount. I tried plugging it into two Windows computers - same result. The blue power light is on and stays on consistently.
I've tried restarting the computers, plugging into different USB ports, and using a different USB cable. What would cause the drive to fail like that? I there anything that can be done to fix this without losing the data that's already on the Iomega?

Thanks - Steve

Best solution

a b G Storage
June 24, 2012 5:24:31 AM

well either the hard disk itself is defective, or the external enclosure is. you can remove the drive from the enclosure and put it into a desktop to try to read it, or put it in a different enclosure. good luck!
Share
July 4, 2012 12:01:37 PM

Best answer selected by theoldtory.
m
0
l
!