Sign in with
Sign up | Sign in
Your question

Will an A-Power ACE 1000W work with my system?

Tags:
  • Power Supplies
  • Computer
  • Components
  • Product
Last response: in Components
Share
July 17, 2010 7:10:51 AM

I have just recently built a computer, but I am stumped.

I built my computer and now... It doesnt boot!
I was told it could possibly be a power supply issue, which I thought I had covered, but want a second opinion... heres my specs:

A-Power ACE 1000W power supply ( specs.. http://www.geeks.com/details.asp?invtid=ACE1000&cat=CAS )
ASRock X58 extreme mobo
i7 930 processor
OCZ CL7
HD 5850 video card
320 gb hdd

Please let me know if you think this should be working. I have an older video card ATI X1600 which works fine, but when I hook up the HD 5850 (with the 2 6 pins) it does not boot. Nothing on the screen... mobo has dr. debug and that shows code 2A, I looked up in the manual and it says

"2A Initializes different devices through DIM.
See DIM Code Checkpoints section of document for more information."

Not sure what this means... Please help!

More about : power ace 1000w work system

July 17, 2010 3:25:30 PM

Well, in the manual, it doesnt say anything about it... I found one guy had the same problem http://forums.tweaktown.com/f80/x58-extreme-fails-start...

He only has 520w power supply, thats pretty low... and mine, I think its crap. I didnt do my homework before I got a power supply and thought watts was enough... lesson learned.

I am now going to buy this http://www.newegg.com/Product/Product.aspx?Item=N82E168..., which should be good, its certified with ATI, and I will be able to upgrade to crossfire when I get another card.
m
0
l
!