Sign in with
Sign up | Sign in
Your question
Closed

GA-890XA-UD3 HELP! No Keyboards - stuck on Logoscreen

Last response: in Motherboards
Share
January 27, 2011 9:40:08 PM

Help! First off I'm a noob here on Tom's and back to being a noob with hardware - it's been about 10 years since my last build and things have changed!

The issue is that I'm stuck on the initial mobo logoscreen and neither PS2 or USB keyboards are not working so I can't get into the bios.

System:
MOBO: GIGABYTE GA-890XA-UD3 AM3 AMD 790X SATA 6Gb/s USB 3.0 ATX
CPU: AMD Phenom II X4 970 Black Edition Deneb 3.5GHz 4 x 512KB L2 Cache 6MB L3 Cache Socket AM3 125W - HDZ970FBGMBOX
MEM: CORSAIR XMS3 8GB (2 x 4GB) 240-Pin SDRAM DDR3 1333 - CMX8GX3M2A1333C9
GPU: ATI FirePro V5800 (HP's WL050AT version for about $100 savings)
POWER: Coolmax Modular 700W
CASE: Cooler Master HAF 915 - if it matters.

Best solution

a c 1155 V Motherboard
January 27, 2011 10:29:30 PM

Last time I installed a Gigabyte board I had to use PS2 keyboard since a USB one did not work until I enabled the controller in BIOS. I did not try all the USB connectors some might be native, try swapping the keyboard around if USB.
Share
January 28, 2011 12:38:51 AM

Sorry, I forgot to mention that. Yes, my PS/2 keyboard was the first one I tried. The keyboard's lights were lit (Num/Caps/Scroll Locks) but I couldn't get into the BIOS or anything else.

I then tried my brand new out of the box USB keyboard. Same thing - lights but no navigation. I further tried my old stand-by USB and still nothing.

I doubt I'm the only one who's ever had this issue, so I'm hoping there's a solution besides RMA. Is there a way to bypass the BIOS setup and still be able to boot from Windows disc or some other way to start this process?

Very frustrating.
Score
0
Related resources
January 28, 2011 1:52:20 AM

Yikes! I ran into a similar problem with you when I was messing around with my BIOS after my system was built. I disabled my USB controllers to get Windows 7 to install correctly, and I forgot that I would need my keyboard and mouse (both USB). After some hair pulling, swearing, and ground-pounding, I finally remembered that my old computer has a PS/2 keyboard. I simply plugged it in and was able to use that.

As for your care... both PS/2 AND USB doesn't work? Very peculiar, as most BIOS just has an option to disabled USB and not PS/2..

Best of luck though.
Score
0
February 2, 2011 6:45:24 AM

Best answer selected by jjasonmat.
Score
0
February 2, 2011 6:51:18 AM

Well, after several attempts to resolve this issue with suggestions PMd to me (thanks guys - great to know there's help when needed), I've decided to pursue Newegg RMA as I believe I have a bad PS2 port.

My new issue is that I'm now rethinking Gigabyte vs Asus. I hate to admit it but I may not be as forgiving as I thought!

Thanks again for the suggestions.
Score
0
January 23, 2012 10:14:17 AM

How did you solve it? I exactly have the same problem. PC is stuck on logoscreen and does not respond. It seems there is nothing to do. I don't even know what causes the problem. Any ideas? Motherboard, memory or processor maybe?
Score
0
a c 328 V Motherboard
January 23, 2012 10:49:48 AM

Open a new thread on your problem, that is the best way to get helped Thoamros : )
Score
0
a c 328 V Motherboard
January 23, 2012 10:50:02 AM

This topic has been closed by Nikorr
Score
0
!