Sign-in / Sign-up
Your question
Solved

ST2000DL003 Barracuda Green not detected in XP.. kinda'..

Tags:
  • Hard Drives
  • Storage
Last response: in Storage
June 27, 2012 7:09:17 AM

Hi guys..

New here.. but so happy to join. Every time I have a PC question Google seems to send me to the TH forums first, so I thought I'd become a member. I have built several of my own PCs over the years.. so I'm fairly well versed in most things but this one's got me stumped. This is simply a repost of my question in the Seagate forums a few days back but no one there seems to have a response. Sorry for the lengthy diatribe.

Quote:
I hope someone can help me. I have spent the last two days studying every online resource I could find and I now know a LOT more about hard drive architecture than I did before, but my dilemma remains.

I just bought and recieved this 2TB green hard drive from Newegg. I HAVE seen and studied the rather large thread in here that describes people's problem with the drive not being detected in/by the BIOS.. but that is not my problem at all. A preface.

I recieved the drive and almost immediately.. placed it in my AZiO HD dock to activate, partition and format (The dock can connect via USB 2.0 OR SATA.. but SATA has never worked, probably because my eSATA port is actually a header plate off one of my 4 SATA ports and not a true eSATA backplate I/O. Anyway.. I use USB.). Everything went OK.. and I left all parameters for a NTFS drive in XP (Home 32-bit) at default. The drive was immediately seen IN the USB dock.

I then rebooted into Windows 7 (Home 64-bit) while leaving the drive in the dock, and everything seemed OK there. I even transferred some files to the new drive (about 100 gigs) and it went smoothly and quick.

I also have an Antec internal dock that is wired directly to my mobo (ECS NF650iSLIT-A) via an internal SATA port. ALL of my other prvious HDs (some WD, and most Seagate with caches as big as 32 megs) work fine in both docks and are always seen (The ANZiO USB being hot-swapable, but the Antec not).

I then took the HD out and inserted it into the Antec internal (while PC was off) and botted into the the XP OS. The drive IS showing up in the BIOS and post screen when connected either way. In XP.. when the HD is inserted into the Antec internal.. it does NOT show up in either Windows Explorer, NOR the Disk Management window under Administrative Tools. Oddly enough though.. it does show up under the Device Manager>Disk Drives as ST2000DL 003-9VT199 SCSI Disk Device.. same as my other 250GB Seagate SATA drive does.

I CAN leave the drive in the internal Antec.. reboot into W7 and see/access it again just fine.

I've tried just about every suggestion imaginable offered up here, and in other forums.. mostly by people who couldn't see the drive altogether (Scan for new hardware, rt clk drive in device manager and scan for hardware changes, etc.) and nothing seems to make the drive show up in XP when connected internally through the SATA dock.

I even went so far (after my studies) as to download a partition alignment utility (Thinking that HAD to be why it wasn't seen in XP because of it's ADF 4K sector size, but then.. why does it show up via USB in XP?) and did see that it was misaligned after a complete wipe in Paragon and a reformat in W7.. but that didn't correct the problem either.

One last thing.. when I go the the "Volumes" tab under the drive's properties in Device Manager and click "Populate" it goes from nothing but "dashes" in the info fields.. to:


Disk: Disk 2

Type: Unknown

Staus: Unreadable

Partition Style: Unapplicable

Capacity, Unallocated, Reserve: 0, 0, 0


I'm at a total loss here. I know someone will say: "If the drive is OK hooked up externally via USB.. what's the worry?", but this is my biggest HD and I kind of wanted to keep it in the internal dock all the time (SATA obviously being faster than USB anyway.) and use it as my "archive" drive. Also.. I tend to spend about 90% of my PC time in XP as opposed to W7.

Sorry for the long-winded "read" but I wanted to be thorough with the description of my problem and let everyone know that I've tried all of the usual, quickly offered fixes.

I don't think there's anything wrong with the drive.. just maybe my methods, or XP. BTW.. I checked, and I have the latest firmware as well.. CC3C. Weird.. I JUST checked HD Tune Pro IN XP.. and it even shows up there (SMART info, supported features, temp.. etc.). Obviously.. if I can't see it in Disk Management to do anything to it (partitioned & formatted already, or ''unallocated''), nor see it in Explorer.. I can't read/write access to it either, with files.



I'm running Windows Home XP w/SP3 (32-bit) (the affected OS). I have an Elitegroup ECS NF650iSLIT-A mobo w/4 SATA II ports. 1 holds a storage drive (250GB single-platter Seagate). Another is hooked up to a Samsung DVD-RW. One goes to the Antec internal dock, and the last is connected to a eSATA breakaway in back.

Things I have tried in the last couple of days:

Disconnected the DVD-RW and hooked up the drive directly to the mobo. Still not seen in disk management.

Used Paragon Partition Align (v3) on the drive which DID report it being out of alignment. Still no go in XP.

Partitioned & formatted in in both XP & W7 (XP had to do via USB as that is the only way it's seen).. same thing.

Like I said.. the really odd thing is that the drive works just fine in XP via the USB 2.0 dock. But hooked up SATA.. even though it shows up in Device Manager.. and 3rd party utilities like HD Tune Pro and Crystal Disk see it.. it isn't seen in Disk Management so I can't assign it a letter/path.. and Windows Explorer can't access it as a result. The BIOS and W7 see it just fine (@ full capacity as well) when it's hooked up either way. It's seen by HD Sentinel just fine in W7 as well. Running SeaTools for DOS (long scan) on it reported the drive was just fine. ALL utilities in XP & W7 say SMART has not been tripped.

I know from the Seagate forums that this particular drive has had problems in the past (and currently.. even with the latest firmware) with people not seeing it detected in the BIOS at all, the posts are literally in the hundreds, but that is not my problem.

I thought it had something to do with alignment or the drive's SmartAlign feature.. but that doesn't explain why it's seen OK in XP when hooked up via the USB 2.0 dock.

My greatest fear is that I may have gigs of data transferred to it.. and suddenly lost ALL recognition everywhere.. altogether. (This has happened to many in the forums.. some can't see it in their BIOS initially, and for some the drive has worked fine for awhile.. THEN suddenly disappears. Losing all their data save for a recovery service. If YOU can't access the drive at all.. you can't use recovery utilities on it.)

Thanks to all for your time and attention.

I'm at a REAL loss here.

More about : st2000dl003 barracuda green detected kinda

Best solution

a c 464 G Storage
June 28, 2012 1:53:40 AM

My suspicion is that you don't have a driver installed.

Win XP in all its forms does NOT have a driver "built in" for AHCI devices (the true nature of a SATA unit). Win Vista and Win 7 DO have their own drivers built in, so they can use SATA drives right away. And when you mount your SATA unit in an external case connected via USB, it's actually the SATA controller in the external case that is using the drive, not Windows itself. I am guessing that, when you say you mount it in an Antec "internal dock", you mean it is just connected to a mobo SATA port like any normal internal HDD.

Since this is NOT your boot device - you seem to want to use it as a data storage unit - the solution may be quite simple, because essentially Win XP will have loaded itself plus all installed drivers (from the boot drive) BEFORE it needs to access this drive.

So, how to fix? The straightforward way is, with Win XP running and the HDD installed in the Antec dock, you must install the AHCI device driver. Probably the best way for this is to look at the CD of utilities and drivers that came with your computer or its mobo. Look for a way to install for Win XP a driver for AHCI, or maybe for a "SATA drive". If you don't have such a disk, an alternative might be to check for the HDD in Control Panel ... System ... Hardware ... Device Manager, and choose to Update the Driver for this device. Windows probably has a driver available, just not actually loaded.

The alternative is to use a work-around built into most BIOS's. Instead of installing the driver and using it as an AHCI device, you can go into BIOS Setup and find the area where you Enable the SATA ports. Look for a line something like "SATA Port Mode", with choices like "IDE (or PATA) Emulation", Native SATA', AHCI", or "RAID". If you set this to "IDE (or PATA) Emulation", the BIOS will intervene and make the actual SATA drive appear to Windows to be a plain old IDE drive that it DOES understand. (This slightly limits a few features of a SATA drive, but you probably don't need them.) If you do this, don't forget to Save and Exit. With this setting, Win XP will not need to have an AHCI or SATA device driver loaded to be able to use the drive.
Share
June 28, 2012 10:12:09 PM

Paperdoc.. thank you..

After coming home last night and seeing your reply I had typed out another lengthy follow-up but neglected to see that I wasn't logged in so when I hit the submit button I lost it all (LOL.. I hate it when that happens.. I usually save a reply before submitting; learnt from many years.).

I'd already been studying up on AHCI and your explanation makes perfect sense as to why the drive is seen in some places in both OS'es.. hooked up different ways. My older mobo has a nForce 6XX series chipset and I found out through further investigation that Nvidia chips of that era did not support AHCI. I also saw many suggestions about the IDE>SATA>AHCI>RAID setting in the BIOS but I have thoroughly scoured my BIOS settings and although the board supports RAID and has settings for it (I even tried enabling it thinking if I reinstalled the nForce drivers it may help.) and enabling various combinations of the IDE & SATA ports.. but nothing for setting HD channel modes. Which leads me to believe that even perhaps this mobo (4 SATA, 2 PATA) simply ''emulates'' it's SATA support as IDE channels (All ports show up in BIOS and post as ''IDE'').

In this case.. I don't think there's anything I can do. From what I understand and have garnered only Intel chipsets had ''true'' AHCI support at the time and even though I've searched for AHCI drivers for my Nvidia chipset everywhere.. I find no joy, nor a workaround. Your explanation as to why the HD IS seen via the USB dock in XP makes sense to me. The dock IS able to be hooked up via eSATA as well, but I tried this months back and it wasn't working as I now suspect that had to do with the fact that I had to run a eSATA breakaway off the back of my case, but hooked up internally to one of my straight SATA ports. In other words I didn't have a real eSATA port built INTO the mobo.

I think I'm just screwed.. but it's not a critical factor as I do really have some kind of access in both XP and W7.. I'll just have to use W7 via the Antec for large transfers.

Thank you very much for all your help. I love learning new stuff.
m
0
l
Related resources
a c 464 G Storage
July 1, 2012 3:18:01 PM

When your HDD is in the external case and connected to the computer via eSATA, in fact there is almost no "smarts" between your computer's SATA port and yout HDD. eSATA does not need it - the computer's eSATA port (well, in your case, actually a plain SATA port) does all the work. So in that configuration, it's the same as if your HDD were mounted as an internal drive. And you already understand why that does not work. So that malfunction is NOT because your adapter bracket is no good - it's probably just fine.
m
0
l
July 2, 2012 6:52:40 AM

Best answer selected by emdeesee.
m
0
l