Sign in with
Sign up | Sign in
Your question

Have to type "http" before address in IE??

Last response: in Networking
Share
September 9, 2004 9:19:51 PM

I'm working on a PC right now that had a boat load of viruses, spyware, hijacks, etc. Everything is fine now except for one thing.

In Internet Explorer, typically you can enter an address (ie. "www.ebay.com") and it goes. However, for some reason now, I have to type the http:// before the address (ie. "http://www.ebay.com") for it to work. Otherwise I immediately get an "unable to access" page. It's rather annoying to always enter the hypertext prefix.

I assume there is some helper object or host file that is missing, corrupt, etc. but I'm not sure. Never ran into this problem and just curious if anyone could help me out.

THANKS!

More about : type http address

September 10, 2004 1:04:25 AM

try this:

type

ebay then <ctrl>ENTER (ctrl and enter at the same time)

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
September 15, 2004 1:49:42 AM

I actually figured the problem out on my own after searching the registry for awhile. There's actually a default prefix setting in the registry for all URLs:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\DefaultPrefix

that sets "http://" to be default. Somehow or another this got deleted so "www.ebay.com" didn't do squat. Who'd a thought it'd be that easy.

Good way to make someone mad....delete the prefix :) 
Related resources
!