Sign in with
Sign up | Sign in
Your question

HD will not show in BIOS

Tags:
  • Hard Drives
  • BIOS
  • HD
  • Storage
Last response: in Storage
Share
June 28, 2012 4:28:09 PM

Hello,

My new Seagate Barracuda 2TB 7200 hard drive will now show up on my BIOS (ASUS P8Z77-V Pro). I have tried:

-New ports
-Checking cables
-Switching to IDE in the BIOS

Currently I have a SSD installed as well as my old 250gb HD. Both work fine (and I've tried the same SATA port that the 250gb is in with the 2TB but no luck). I've also tried only running my SDD with my 2TB but still no detection. Power seems to work fine on the HD.

Also of note, a few different times when I started windows up with my HD connected, the mobo had a feint beeping noise every couple of seconds (I say the mobo, though I could've sworn it was coming from my HD...I guess an HD making noise doesn't make sense though, heh). But, once again, all cables are secure and the HD is properly powered.

Edit: Also I noticed that my HD required a 6GB Sata connection--which before I had only tried the 3GBs.... Well I tried it and still nothing worked. Pretty bummed.

More about : show bios

a c 84 G Storage
June 28, 2012 7:31:47 PM

Is the drive detected in other systems? If not, then it most likely is defective.
June 28, 2012 8:20:54 PM

Not sure but I will check when I get home from work tonight.
Related resources
a c 138 G Storage
June 28, 2012 8:42:42 PM

most time those slight beep where the drive trying to spin up and failing. sound like the drive was dropped in shipping and the heads crashed.
June 29, 2012 5:09:48 AM

Unfortunately my friend's MOBO doesn't support 6GB Sata connections so I can't test it out...

But if what you say is true about the beeping, then yea I probably have a poor drive. Guess it's time to send it back to the manufacturer.

Thanks for the help guys.
a c 84 G Storage
June 29, 2012 5:34:31 PM

The drive should work on a 3 and 6G SATA connection.
July 16, 2012 5:29:44 PM

You're right Ghislain, the specifications said compatible with 3G.

I just had my HD replaced and the new one works perfectly, seems it was indeed defective. Thanks for the help fellows.
!