How to enable HPET on my Rampage III MoBo

I can't seem to find the HPET in the bios of my Rampage III Extreme MoBo to Enable the HPET to 64bit mode any help as to how I may find it or what I can do to change it to 64bit mode???
3 answers Last reply
More about enable hpet rampage mobo
  1. To my understanding, ASUS has removed the HPET 32/64 bit {ON} options and by default it is Disabled and no accessible. There are more CONS than there are PROS and HPET has been shown to be the root cause of OC and Stability issues.
  2. On this mainboard, HPET is enabled by setting ACPI 2.0 to enabled in the bios
  3. "There are more CONS than there are PROS and HPET has been shown to be the root cause of OC and Stability issues. "

    complete and utter tripe.
Ask a new question

Read More

Chipsets BIOS Rampage Motherboards