Sign in with
Sign up | Sign in
Your question

Vista can't detect SSD during OS install

Last response: in Storage
Share
June 28, 2012 8:08:54 PM

I have an eMachines T3395 desktop.

I bought an Corsair Force Series 3 120gb SSD and a Sabrent Sata host controller and molex to sata power cable.

I have the hose controller installed in one of the PCI slots, and the SSD plugged in. There is a little red light coming from the inside of the SSD, so I am assuming it has power.


During OS install, when I get to the point to select the drive, there is no drive there. I clicked to install drivers, which I am assuming is the driver for the controller. I had, what I thought was the correct files, on a thumbdrive. However, when clicking to install the controller drivers, it says there are no drivers there.

I know the controller and SSD are good. I have tested the SSD on a laptop, and when I boot up using my HHD, it finds the controller, but still doesn't show the SSD drive under "my computer".


Any help would be fantastic as I am stuck on this one.
a b G Storage
June 28, 2012 9:25:51 PM

Yep there's your problem right there. Windows will not be able to see the drive until you have installed the correct controller driver. please consult with Sabrent about how to install windows on their controller.

jst1cam said:
During OS install, when I get to the point to select the drive, there is no drive there. I clicked to install drivers, which I am assuming is the driver for the controller. I had, what I thought was the correct files, on a thumbdrive. However, when clicking to install the controller drivers, it says there are no drivers there.
m
0
l
June 29, 2012 6:15:03 PM

nhasian said:
Yep there's your problem right there. Windows will not be able to see the drive until you have installed the correct controller driver. please consult with Sabrent about how to install windows on their controller.

Seems as though Sabrent's tech support is pretty bad. I was told to go to the Silicon Image site with the controller and they guide, etc will be on the right hand side. However, there is no guide there and now they seem unable to help me.




Can I use a IDE to SATA adapter to make this drive work?
m
0
l
Related resources
a b G Storage
June 29, 2012 7:06:25 PM

yes that would work as well
m
0
l
a c 125 G Storage
June 29, 2012 8:20:11 PM

http://www.siliconimage.com/support/index.aspx
you have to pull the list down to see if you get t the right driver for your card.
make sure you expand the drivers onto the usb stick and the inf is in the root of the usb stick and not in a folder.
m
0
l
June 29, 2012 9:18:24 PM

It is the Sil3512 and OS is 32-bit Vista.

http://www.siliconimage.com/support/searchresults.aspx?...

Do I need the IDE driver or the BASE non-raid driver??



Also, before the OS boots from disk, the controller tells me to press ctrl+s or F4. However, when I do that, it says "no device detected, utility disabled" Should I skip pressing anything at that point and just go into boot, then install the driver when it prompts?!?
m
0
l
a c 125 G Storage
June 30, 2012 7:51:12 AM

should leave the controller alone and use windows f6 to install the ide driver so that windows will see the controller.
m
0
l
!