Sign in with
Sign up | Sign in
Your question

AMD Cool n Quiet not functioning properly?

Tags:
Last response: in CPUs
Share
July 20, 2010 6:51:33 AM

Got a few questions about AMD's Cool n Quiet Tech. It seems as if mine is not functioning properly? I have a x4 630 cpu and the biostar TA760G mobo. The correct clock speed is 2.8 MHz. I am running everything stock, no overclocking.

From what I understand, Cool n Quiet underclocks the CPU while doing regular, non-intensive applications and idling. Thats fine. It works perfectly in that sense and I'm happy with the resulting lower CPU fan speed and temperatures. The System Properties in Windows XP shows it running at 784 MHz.

I had just upgraded to this CPU/mobo from a 5000+ BE and some other mobo and I ran games like SC2 fairly well on medium or high settings. When playing SC2 last night I found it incredibly choppy, even at times on Low or Medium. This led me to believe that Cool n Quiet wasn't properly clocking the CPU speed back to its 2.8 GHz standard.

Has anyone else run into this problem? I later tested it by switching the setting in Power Options to 'Always On' instead of 'Minimal Power Management', which I guess turns off CnQ? System properties showed 2.8 MHz again and I was able to run SC2 perfectly on all high settings. It also worked when I just completely uninstalled CnQ altogether.

Ideally I'd like to keep the features of CnQ for when I'm just browsing the web or things of that nature, and have it correctly up the CPU power when gaming. Anyone have any ideas to fix this issue? Otherwise I'd have to go into Power Options and change it to 'always on' everytime before gaming, or just lose the CnQ features all together and have the CPU run at full speed at all times.

Sorry for the long post, hope I sufficiently explained the problem
a c 131 à CPUs
a b À AMD
July 20, 2010 7:03:11 AM

Power Options to 'Always On' instead of 'Minimal Power Management'
I do not recognize those settings. What OS are you running?

To solve the issue, I would update the bios to ensure proper compatibility.
http://www.biostar.com.tw/app/en/mb/bios.php?S_ID=393
I suggest this because the 630 is a relatively newer CPU.

If this does not work than the issue could be with windows, but I need to know what version you have.

Windows options do not disable cool n quiet. If you still have an issue after trying the above, disable cool n quiet in the bios. Likely found under something like "cpu management"
m
0
l
a b à CPUs
July 20, 2010 7:09:15 AM

I think you've diagnosed the problem quite well. I've never experienced this personally, but other people have. For some reason, the CPU doesn't always detect that it's supposed to ramp up, and then stays stuck at the idle clocks.

I assume this is still the SC2 beta you are running? You could try re-installing it, or at the very least see if other games give you the same problem. Next step would be to ensure that all your motherboard and CPU drivers are up to date.
m
0
l
Related resources
a c 131 à CPUs
a b À AMD
July 20, 2010 7:10:32 AM

Herr_Koos said:
CPU drivers are up to date.

CPU drivers? lol
m
0
l
a b à CPUs
July 20, 2010 7:11:35 AM

enzo matrix said:
Power Options to 'Always On' instead of 'Minimal Power Management'
I do not recognize those settings. What OS are you running?

To solve the issue, I would update the bios to ensure proper compatibility.
http://www.biostar.com.tw/app/en/mb/bios.php?S_ID=393
I suggest this because the 630 is a relatively newer CPU.

If this does not work than the issue could be with windows, but I need to know what version you have.

Windows options do not disable cool n quiet. If you still have an issue after trying the above, disable cool n quiet in the bios. Likely found under something like "cpu management"


Those are Windows XP terms, and yes, they can disable Cool N Quiet. In XP, Cool n Quiet only activates if you set your Power Management profile to "Minimal Power Management". "Always On" will prevent it from working. Not sure why, but I saw the exact same thing first-hand.
m
0
l
July 20, 2010 7:24:18 AM

Yes, I'm using XP, and the temporary solutions I listed are the only options I'm aware of at this point. I appreciate the responses so far though.

This problem isn't just specific to this Starcraft 2 beta, as I've experienced it with even Street Fighter 4 PC and other games. Oddly enough, some games seem to run just fine, such as the new Medal of Honor Beta, which being new, I assumed should have fairly high system requirements as well and would cause my computer, with CnQ active to stutter.

I also used the bios update tool provided with the CD that came with the motherboard and it checked online to verify that I was using the most recent bios firmware.
m
0
l
a c 131 à CPUs
a b À AMD
July 20, 2010 3:22:39 PM

Herr_Koos said:
FYI, AMD does publish updates on their site for CPU's, and yes, they call them drivers. See here:

http://support.amd.com/us/Pages/AMDSupportHub.aspx

An entire section called "Processor Drivers".


I've used them before on my TL-50. I found them to be useless. lol

They are only for the K8 architecture and early phenom anyway. Haven't been updated since 2007.
m
0
l
July 21, 2010 12:50:55 AM

Anyone else have any other ideas?
m
0
l
July 21, 2010 1:02:08 AM

There were some XP updates for this problem... It's been a long time though.

You could try to limit the cpu cores used in a game.
m
0
l
July 21, 2010 5:46:37 AM

r-sky said:
There were some XP updates for this problem... It's been a long time though.

You could try to limit the cpu cores used in a game.


The problem was not limiting the cores. If anything, its the opposite, that the cores are being limited by CnQ and not going back to full potential when its supposed to (playing games).
m
0
l
a b à CPUs
July 21, 2010 1:31:04 PM

Try using the K10Stat, it works wonders for me since I undervolt my CPU to save money for the electrical bills...lol

In your case, the software will perfect the C 'n Q performance. Furthermore, it will serve as a monitor and controller for your CPU ramping. You can set the work load on each p-states, in my preference 60% up and 20% down. You'll understand when you see it.

Hope this helps
m
0
l
July 21, 2010 9:42:10 PM

damasvara said:
Try using the K10Stat, it works wonders for me since I undervolt my CPU to save money for the electrical bills...lol

In your case, the software will perfect the C 'n Q performance. Furthermore, it will serve as a monitor and controller for your CPU ramping. You can set the work load on each p-states, in my preference 60% up and 20% down. You'll understand when you see it.

Hope this helps


I'll check it out, Thanks!
m
0
l
!