Sign in with
Sign up | Sign in
Your question

Total Stumper: can't remove Task Manager "Users" tab

Last response: in Windows XP
Share
February 2, 2013 2:00:47 PM

Here's a TOTAL stumper: the "Users" tab is ALWAYS showing in Windows Task Manager on my system...

Background:
I have a Dell Inspiron 5150 notebook running Windows XP Home Edition (SP3).
The OS and all software are up to date. All Microsoft Updates installed.
All windows services are set to their default settings.
I am the only user (only one user account on this computer).
I have Fast User Switching DISABLED.
If it matters (that darned Google...) I have Microsoft .NET Framework
versions 1.1, 2.0 SP2, 3.0 SP2, 3.5 SP1 and 4.0 (client profile/extended) installed and up to date.

The computer runs like a dream - slick as can be, and like greased lightning (so I guess that means my question shouldn't matter. Yes, it's basically a challenge for anyone bored enough to try to figure it out!),
and I am seeing no errors in the Administrative Tools Event Viewer.


So here is the problem/question...

If I open my Windows Task Manager I see the normal tabs:
Applications, Processes, Performance and Networking.

BUT I also see the Users tab.


From what I understand after a hearty session of Googling, the Users tab is ONLY supposed to be present when Fast User Switching is enabled.

I have experimented with enabling/disabling Fast User Switching, and checked/unchecked "Use the Welcome Screen". The system restarts, shutdowns, logoffs and logons work exactly as expected for each configuration.

Also, the DWORD value for AllowMultipleTSSessions under the registry key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

(that is supposed to control whether or not the Users tab appears)
is present and is correctly toggled when Fast User Switching:

When Fast User Switching enabled > AllowMultipleTSSessions value = 1
When Fast User Switching disabled > AllowMultipleTSSessions value = 0


BUT... the Users tab does NOT disappear as it is supposed to when Fast User Switching is disabled, even though the AllowMultipleTSSessions value is correctly set to 0 to hide the Users tab.


In a nutshell, here is what I see:





As far as I know, this is not a new problem. I think the tab has always been visible on this computer.

Also, I have another 5150 notebook set up basically the same (except running XP PRO SP3), and the Users tab on THAT computer shows and hides like it's supposed to!

I can find no references to a similar problem anywhere on the web...


So how about it - anyone have a suggestion or solution?

Thanks!!

Ken
February 2, 2013 2:42:36 PM

Disable fast user switching compatability in services.
m
0
l
February 2, 2013 4:08:47 PM

Quote:
Disable fast user switching compatability in services.


Thanks for the suggestion, ktownmike.

Sorry, but disabling Fast User Switching Compatibility service didn't work. That Users tab is still nailed in place!

Prior to my original post I had checked what was happening with that service on my system:

Default setting for Fast User Switching Compatibility service is Manual.
The service starts up as expected when I enable Fast User Switching.
The service stops as expected when I disable Fast User Switching.

If I set the Fast User Switching Compatibility service to disabled (and reboot)
the service is indeed disabled,
but the Users tab STILL shows up in Task Manager
(whether or not I check/uncheck the Fast User Switching option in User Accounts).


I should ALSO add that I have seen a suggestion that disabling the Terminal Services service will remove the Users tab...

I have already tried that, with the following result:
As you can see in the image attached to my initial post, the Users tab is present and populated with me "Ken" as the active user, session>console.
When I disable the Terminal Services service, the Users tab is still present, but empty.



Next?!?!
m
0
l
Related resources
Can't find your answer ? Ask !
February 2, 2013 7:33:49 PM

I started the service, users was there, I stopped the service users was gone. Perhaps your AV is preventing saving changes. You can try disabling access protection if you have it and using autoruns from sysinternals with av disabled can help you see what is happening and turn them off from there.
m
0
l
February 2, 2013 9:28:02 PM

I am using AVG AntiVirus 2013 Free Edition.

I doubt it has anything to do with this problem. I did try temporarily disabling AVG self-protection, and disabling the virus protection, and it made no difference.

AVG has never interfered with anything I have done in the past (including messing around starting/stopping/disabling various services trying to troubleshoot this problem :D  ).

[Wait... there is one thing AVG ABSOLUTELY does prevent: Performing Diskeeper 2011's boot-time defragment function is impossible unless AVG is completely uninstalled from the system.]

As I stated previously, all functional changes expected when I enable/disable Fast User Switching (including correct toggling of registry keys and starting/stopping the Fast User Switching Compatibility service) are saved, even through reboots. The various logon/logoff modes work exactly as expected, so nothing is interfering with saving configuration changes.

It's just that the Users tab doesn't disappear when Fast User Switching is disabled...
m
0
l
February 5, 2013 12:14:26 PM

Just a thought...

Is it possible that the answer to this "problem" is that the Users tab is SUPPOSED to be always present and visible in the Administrator account (regardless of whether Fast User Switching is enabled/disabled)
if the Administrator account is the only user account installed on the system?

I have thoroughly "Googled" the question, and I can't find any info regarding this possibility.


(Although I probably answered my own question - as I mentioned in my initial post, I have another Dell Inspiron 5150 set up similarly, but with XP professional, and I have only one account installed on THAT one. The Users tab behaves fine and "follows directions"...)
m
0
l
!