Sign in with
Sign up | Sign in
Your question

GTX 470 STEAM (left 4 dead 2) UNKNOWN Video CARD?

Last response: in Graphics & Displays
Share
April 15, 2010 5:26:14 PM

Hi guys,
I just brought Asus gtx 470, install latest drivers and stuff. Play Crysis max, Metero2033 max except for Crysis Anit-Alisaing can't max it on 16xQ or else performance lag...ANYWAY

When I go into STEAM, and click play for LEFT 4 Dead 2, it comes out a message saing "Unknow video Card" error message. Basically STEAM or "Left 4 Dead 2" not reconizing the new gtx 400 series... ANYONE ever got this message or who owned a gtx 400 series tried out and got the same problem..

HELP Anyone know how to solve this problem?? I have Window 7 Ulimate x64 bit...
April 15, 2010 5:38:02 PM

alricking113 said:
Hi guys,
I just brought Asus gtx 470, install latest drivers and stuff. Play Crysis max, Metero2033 max except for Crysis Anit-Alisaing can't max it on 16xQ or else performance lag...ANYWAY

When I go into STEAM, and click play for LEFT 4 Dead 2, it comes out a message saing "Unknow video Card" error message. Basically STEAM or "Left 4 Dead 2" not reconizing the new gtx 400 series... ANYONE ever got this message or who owned a gtx 400 series tried out and got the same problem..

HELP Anyone know how to solve this problem?? I have Window 7 Ulimate x64 bit...



Here's the link to the message error that someone else having same problem as I am, but different video card...SAME MESSAGE error display.

http://www.sevenforums.com/gaming/25623-steam-counter-s...
m
0
l
a b U Graphics card
April 15, 2010 8:24:51 PM

Thats strange, did you install the drivers properly?

Try uninstalling the drivers and reinstalling them, tedious i know but it might be whats needed.

Also steam may need time to simply update the database, the 4 series are brand new. The update may come with the UI upgrade coming to steam in the next few weeks.
m
0
l
Related resources
April 15, 2010 8:30:21 PM

I think I reinstall the latest drivers a few times, still doing it.. hmm.. maybe it is STEAM problem side since they not updated their database with new GTX 400 series.. thats what I am hoping...
m
0
l
a b U Graphics card
April 15, 2010 8:42:10 PM

Have you emailed about it? If it is a problem on their side then they'll openly admit it.
m
0
l
April 17, 2010 7:05:24 PM

I'm having the same problem. EVGA GTX 470 and I am getting the error message and then when I fire up L4D2 it plays the opening movie and then crashes when it tries to load. The original L4D game works fine though, which seems weird if it's their data base that needs updating shouldn't it affect all steam games?
m
0
l
April 17, 2010 7:44:27 PM

You know what, I play Left 4 dead 2 anyway and just manually change the graphic setting, everything is working fine now.. dunno why your EVGA gtx 470 crashing in left 4 dead 2 while my Asus gtx 470 doesn't... I overclocked my gtx 470.. did you overclock your EVGA gtx 470? up to how much :) )) lets share some information..
m
0
l
April 17, 2010 11:40:55 PM

It is the superclocked version so the processor is at 1250 and the memory is at 1701. I would change the settings but it crashes before I get to the screen.
m
0
l
April 18, 2010 7:31:28 AM

WTF.. how come you can't overclock it anymore? my asus gtx 470, i was able to push it at least to

Core Frequency: 700
Shader Processor: 1400
Memory Frequency: 1700

You sure you can't overclock it ..thats strange..
m
0
l
April 19, 2010 6:27:05 PM

hmmm I was about to pick up a 470 but I think I will wait. I play LFD2 almost every day so I don't want any down time. lol ....Actually i just don't want the headache associated with crap like this.

Have you tried a clean driver install after running driver sweep in safe mode ? Try the default Win 7 driver. Make sure on-board VGA is disabled. I had an issue identical to yours with BC2 ( which I run off steam ) with a driver a few updates back. What I finally determined it to be was the on screen display of EVGA Precision. I disabled it and no more crashing ? Are you using Precision or Afterburner ? If so , try without OSD.

Seeing as you can play other games that are not Steam client based I would chalk it up to Steam compatibility issues. If this is indeed the fact I would think they already know about it and are currently working on a solution.

m
0
l
Anonymous
a b U Graphics card
July 22, 2010 4:35:16 PM

Its a compatibility issue. I had the same prob . L4D said "unknown card" for me as well. My comp would crash all the time in game or just browsing on the desktop. I have windows 7 64 bit and it kept diagnosing it as a video card prob. Even with the fresh driver install from nvidia. Had no choice but to scrap the card and get the latest from ATI . No problems since.
m
0
l
July 22, 2010 6:39:09 PM

Well since you opened a thread 3 months old I feel I am inclined to comment.

I picked up a 470 and received this error as well on the first steam launch. I simply closed steam / reopened and everything was fine. No need to run to ATI. :/ 
m
0
l
July 23, 2010 6:37:44 PM

roush2fast said:
Well since you opened a thread 3 months old I feel I am inclined to comment.
I picked up a 470 and received this error as well on the first steam launch. I simply closed steam / reopened and everything was fine. No need to run to ATI. :/ 


Yeah, it's just a warning: happens on the GT330 card in my laptop too but the game plays fine.
m
0
l
!