Sign in with
Sign up | Sign in
Your question

5870 drivers and power

Last response: in Graphics & Displays
Share
April 16, 2010 1:43:35 PM

i got an 5870 i download drivers istall drivers but nothing really happends, i restart my computer i get a popup register your ati today... nothing more. the installer is ati 10.3, with every program included

I run my pc with 1 psu and my graphic card with another. the psu that is connected to the card is 15a/12v and its recommended to use 16a/12v, this should matter? is this why my computer cannot find the card and the card cannot find the screen? is it bad for my card then? im going to buy a new psu soon.

And also with out any drivers installed the graphic card sound like hell i mean like 10 times higher than my other ati, seriously. Sound like fan is at 100% all the time, but i havent changed any options or anything.

Also every time i start windows it auto-installs the modercards graphiccard which is like x1100 or something like that

More about : 5870 drivers power

a b U Graphics card
a b \ Driver
April 16, 2010 1:57:26 PM

Could you list your full PSU specs and brand? It sounds like you are underpowering your card by a bit.
April 17, 2010 7:53:55 AM

EXT64 said:
Could you list your full PSU specs and brand? It sounds like you are underpowering your card by a bit.

corsair 400w something. But i have this thing connected to the computer, which shows how much voltage the psu gives or something like that (~12v). Btw the problem is solved but i have another problem. When i start catalyst control center my scrren look like *** and i get an bluescreen. this happend after i overclocked the device, everything runned smoothly until i restarted my computer. what can i do? i can stil play games but dunno if its stable (even like crysis @ entusiast)
!