Sign in with
Sign up | Sign in
Your question

5870 won't see dvi connections

Last response: in Graphics & Displays
Share
April 17, 2010 3:41:30 AM

Hi,

I have a saphire 5870 and 3 nec EA231's. I'm running windows 7 x64 pro, and have the catalyst 10.4 preview driver installed.

I plugged in two ea231's in the two dvi ports on my 5870 and one ea231 via displayport.
The only monitor to even show post is the displayport connected one. Windows and CCC don't detect the two dvi monitors.
This is driving me crazy.
I tried 3 other monitors on the dvi ports, none even light up at post.
I tried this on another machine with a 5750, same scenario, the dvi connected monitors won't light up at post.
I tried rolling back to the 10.3 driver, this made no difference. Both cards were working fine before I plugged in the 3 new monitors.
I've tried checking and unchecking every box in ccc I can find, and nothing changes the dvi connected monitors not being detected, even on boot.

I've googled this and found nothing, so I'm posting here, hoping that someone can tell me what to do

Thanks for reading,

Alex, a guy who reeeeeallly wants to play bc2 with eyefinity....
Edit/Delete Message

More about : 5870 dvi connections

April 17, 2010 3:47:43 AM

As a start, try using only the DVI ports to two monitors to make sure that the dvi ports work.

Then plug in the display port only to make sure that that works.

After that, try following the steps over to set up eyefinity.
April 17, 2010 3:20:25 PM

soundefx,

Thank you for your reply.
The two dvi ports on my 5870 and on my 5750 don't seem to put out any signal at the moment.
The things is, both cards have been driving signal via dvi to 3 other (2 dells and a samsung) monitors for months, and I independently tested all three ea231's on a third machine (with onboard graphics) via dvi, and they all work.
The dvi signal seems to have stopped on my 5870 and 5750 immediately after I plugged in my new ea231's, two via dvi and one via displayport.
The computer with the 5870 and the computer with the 5750 were both running windows 7 64 bit and both were using catalyst 10.4.
It's as if plugging in my new monitors changed something in the gfx card bios so that it won't put out signal anymore.
One other thing I realized is that the monitors originally connected to the 5870 and 5750 were all dual-link DVI, and the new monitors are all single-link DVI, but I have no idea how this would matter.

Again, thanks for the reply.

KromSauce
Related resources
April 24, 2011 3:30:58 PM

Hi, I have the exact same problem with my Sapphire 5870. It was working fine, plugged it into new machine as a secondary card for crossfire. Tried it on its own, DVI doesnt work but DP does. Seems like the DVI ports just died?
!