ASROCK P67 EXTREME6 DEAD?

Hi guys new member here..

I have an ASROCK EXTREME6 P67 and 2600K,it was running perfect then it just shut off,when I restarted all that would come on is the fans and a code 19 on the display..
I have tried everything I know,I reset CMOS took out the battery and let it sit for a while,removed everything and reseated..Tried one stick on memory in each slot,I tried another PSU..
I took the CPU out and reseated it also,there was no smell or burned pins,everything looks great..

Here is my setup.
NZXT Tempest EVO-ASROCK EXTREME 6-Intel 2600K @ 4.6GHZ @ 1.225v-Corsair H70-8GB Corsair Vengeance 1866-PNY GTX 580-Intel X25 120GB SSD-2 WD 650 GB HDDs-SilverStone ST 85F-P PSU

Any help would be awesome..Thanks
8 answers Last reply
More about asrock extreme6 dead
  1. Dave65, welcome to the Forum!

    Please make sure that the 8-pin as well as the 24-pin power plugs are firmly seated. Ensure that the RAM modules are firmly seated; re-install the RAM modules if necessary.

    Here is a great trouble-shooting guide: http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems

    I did some digging and came up with this: http://forums.tweaktown.com/asrock/42757-p67-extreme6-memory-issue-config.html

    Check the manual for "code 19"
  2. Thank you for that nice welcome Ubrales:)

    I had forgot to mention that I had checked the 8 pin connector and had checked the code in the manual has something to do with starting up memory..Only thing I didn't try is different ram,but I did test the ram form this board on a P55 board and it works..
    It ran for a week with no issues was the easiest build I had ever done frankly..
    I took the board out and put it on my bench and still same problem..I may for the heck of it try my Corsair XMS3 and see if that does anything,probably grasping at straws here but once you have had SB it is hard to go without for 2 or 3 month till the SATA issue is worked out..
  3. Yeah, try the XMS!

    In addition, you may want to check the RAM voltage. Change from auto to manual, and up the voltage slightly, while staying well within the manufacturer's max voltage limit. Leave some headroom.
  4. Can't check voltage,it won't post..But before it quit it was @ 1.5 ..
  5. Check it after installing the XMS - I have Corsair Dominator and the voltage is set to 1.55 volts because I had some problems when the voltage was set to 1.5 volts, because of my overclocking.

    My i7-920 is overclocked to 3.82 GHz from the stock 2.66 GHz. My RAM is slightly underclocked from 1600 to 1452 MHz.
  6. What were you doing when it shut off? Were you tweaking the clocks via software in the OS?
  7. It was idle,wasn't doing anything,i had walked away for a few minutes and came back it was off..
    The XMS3 didnt work,just the fans spin up with code 19 same as before..I guess ill box it up and send back..
    Wish I knew if it was the CPU or the board..
  8. Anyway thanks for the replies:))
Ask a new question

Read More

Motherboards ASrock