Sign in with
Sign up | Sign in
Your question
Solved

Ide/sata issue in bios

Last response: in Motherboards
Share
February 6, 2011 10:41:48 PM

hello everyone, i just want to start by saying thank you to everyone who posts here, i've been muddling my way through building and setting up a pc for the first time and got a lot of help from these pages.

i've finaly got my system up and running and aside from a pretty hot mobo temp (52 C) everything is in good working order. there is one small matter which has me really confused though...i set up xp on a sata hdd with raid disabled as initially was installing xp and didn't have the ability to pre-install the sata drivers. in this case the drive showed up in bios under third ide channel. my cd and dvd roms are under 2nd channel and now i've installed a ide hdd under the first channel and have it set as slave with jumper(don't think this matters when using sata and ide together but thought i'd set it to be sure). the issue is that when i set bios to recognize this ide hdd (i.e. to auto-detect) it shows up in bios and i set the hdd priority and boot priority to use the sata drive first with o/s on it and then it fails and gets stuck in a loop of booting but failing to load the o/s?

i then tried enabling raid just as a shot in the dark and that gets me as far as the "windows didn't start properly" screen but when i start windows normally it re boots? finally i disabled the auto detect for 1st ide channels so the ide hdd drive doesn't register in bios but low and behold the system starts and prompts me to update drivers for the new hardware at which point it located and installed sata raid drivers for xp. it boots and loads the os fine now and windows recognizes both hdd but i'm confused as to why the settings work in this way and i'm still not sure whether or not my sata HDD is working properly as a sata or still being used like ide? should i just be happy that all is working or am i sacrificing performance from my two hdd because i haven't configured bios properly? any and all help and suggestions will be greatly appreciated!

System Specs;

ASUS a8n32-sli deluxe mobo
AMI v.02.58 Bios 1303
WD500gb SATA HDD (Black Caviar)
WD200gb IDE HDD
nVIDIA SATA and SATA RAID Drivers are installed as well as up to date IDE controllers

thanks again,

ryan

More about : ide sata issue bios

a b V Motherboard
February 6, 2011 11:27:39 PM

You must set the IDE drive as master, if you don’t you will get issues such as the ones you are experiencing.
m
0
l
February 7, 2011 1:57:09 AM

ok, so i've moved the jumper between all settings and that's the weirdest part. no matter what the jumper settings on the WD200 IDE drive, it still causes windows not to load and a reboot unless set to "not installed" in BIOS in which case windows loads perfectly and the drive shows and functions normally.

i've reformatted it in windows, i can transfer files back and forth with pretty good speeds so i'm assuming that it's working normally. just doesn't make sense to me and i feel like something is wrong but i guess as long as it's working i won't worry about it.

thanks for your suggestion
m
0
l
Related resources
a b V Motherboard
February 7, 2011 4:57:51 AM

You didn’t say what model Western Digital drive you had but with Western Digital drives in general the jumper should be placed in the neutral position or removed if the drive is the master and is the only drive connected. You only need to set it to master if you have a slave drive connected. Western Digital drives are unique in this respect.
m
0
l
February 7, 2011 8:13:59 PM

sorry i didn't mention earlier but the drive causing the problem is a WD 200 GB PATA (WDC WD2000JB-00GVAO) and unfortunately i have tried every available position with the jumpers including "single" with the jumpers removed and it seems to behave in the same manner regardless? this drive is connected through the primary IDE channel with the slave for that channel set to "not installed" though it made no difference when it was set to auto.

the other drive connected through SATA port 1 is a WDC WD5001AALS-00LWTA0 (500.1GB, SATA300, 3.5", 7200rpm, NCQ, 32MB Cache).

i have bios auto detecting all settings for both and the only thing i've changed was the tranfer rate from 16 to 32 bit but that didn't affect the problem. the settings are as follows for the WD 200 PATA:

LBA: Supported
Block Mode: 16 sectors
PIO Mode: 4
Async DMA: MultiWord DMA-2
Ultra DMA: Ultra DMA-2
S.M.A.R.T Monitoring: Supported

The settings for the WD 500 SATA are identical except the UltraDMA IS set to UltraDMA-6

I started off with only the SATA drive and installed the operating ststem on that drive functioning as IDE device because i had no way to pre-install the drivers. i've since installed the drivers but haven't changed the mode yet because i didn't want to mess things up more. Do you think it would be wise to go through that procedure now and see if it helps with this issue?

When the BIOS is set to auto-detect both devices i have to go into BOOT settings and change the order of Hard Drives so that the WD500 is first and the WD200 is second. BIOS automatically arranges them in the opposite order.

The reason i have to do this is so that the WD500 will show up in the boot priority list. Whichever device is first in the Hard Drive menu is the only one to show up in the Boot Priority along with the DVD ROM. I guess that's normal but i thought i'd mention it in case it was indicitive of other problems?

Could it be a PnP issue? i mean if windows recognizes the device and it works then obviously it can detect the drive regardless of the BIOS settings. I guess this means it's not driver related as well if it works?

I appreciate your continuing help. i'm pretty new at this. my father actually got this gear and tried to build a new computer with old and new parts but couldn't get things up and running so i offered to take over and i'm pretty happy to have been able to sort out all the other issues and although it works now, i'm just bothered by the fact that it doesn't make sese why it works ths way!

thanks again,

ryan
m
0
l

Best solution

a c 717 V Motherboard
February 7, 2011 9:05:09 PM

Possibilities:

Couple of things, first is Boot Priority in the BIOS; IDE needs to be first, second if the SATA HDD had an OS installed then that's where the problem is -- if the SATA & IDE drives were both connect in the PC when the OS was installed on the IDE then some OS files are located on the SATA HDD.

To correct the problem if what I said was true you'll need to: remove the SATA HDD from the MOBO {pull the SATA cord}, reformat the IDE, and reinstall the OS on the IDE.

To confirm this, remove {pull the SATA cord} SATA HDD and reboot. Failure confirms the problem.
Share
February 8, 2011 2:02:59 AM

Best answer selected by mrs315.
m
0
l
February 8, 2011 2:03:06 AM

the OS is definitely installed on the SATA drive because i didn't have the IDE pluggedd in originally. but you're saying i can't have it first in the boot priority, first has to be the IDE drive, so that is the problem.

to correct the problem i would have remove the SATA and install windows on the IDE then plug the SATA back in and remove windows from it?

i've put a bit of work into installing software and updating windows since i did the first install and would prefer not to have to do it all over again. do you think there would be a problem with running things the way are now and just leaving the IDE drive as "not installed" in the BIOS and having windows detect it?
m
0
l
!