Sign in with
Sign up | Sign in
Your question

Experience on Marvell Hyperduo in P8P67 DLX

Last response: in Motherboards
Share
February 7, 2011 12:29:31 AM

Hello,



Has anyone tried hyperduo function on this mobo yet? mind sharing some info a bit? speed? problems? etc?
I am planing to move my ssd n 1 of my raid hdd to Hyperduo. need some advice first...

thanks...
martin
February 11, 2011 1:11:31 AM

I have been attempting to run HyperDuo setup for the past week and have had alot of issues. I have never run this machine any other way so I'm not yet sure HyperDuo is the problem, but here goes:

Components:
Asus P8P67 Deluxe http://www.asus.com/product.aspx?P_ID=FpufhQASBFHNvccl
i7 2600k Sandybridge (Mobo and CPU shipped just before Newegg pulled parts)

16 GB Ram (2 dual channel sets) G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL7D-8GBXH
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

1 Corsair Performance 3 Series CSSD-P364GB2-BRKT 2.5" 64GB SATA III MLC SSD
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

2x Caviar Black WD1002FAEX 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5"
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

1 EVGA 01G-P3-1367-TR GeForce GTX 460 SE (Fermi) 1GB 256-bit GDDR5 PCI Express 2.0 x16
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

PSU CORSAIR CMPSU-650TX 650W RT
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Setup:
I am not using any of the 3Gb/s SATA ports (related to recall) - one WD HDD on Port 0 of Marvell controller, SSD on Port 1.
Other WD HDD on Intel controller with DVD drive. Originally I planned to put OS on SSD, and HDD's in RAID0, then I learned more about HyperDuo and decided to try it.
(I have seen a post that suggests the SSD needs to be on Port 0 of Marvell, and I have seen a post that say's it doesn't matter)


Installed Win7 Enterprise 64bit to Marvell Virtual Disk in capacity mode. Loaded Marvell driver from flash drive during OS install but found driver names didn't really match the manual - Win7 actually recognized the combined drive by itself. (Showed a 931Gb drive and a 991Gb drive - the 991 is the Marvell capacity virtual disk).

After windows booted up following a few bluescreens, I installed drivers from the mobo CD 2 or 3 at a time. After pretty much every install/restart I would get a bsod and take the system restore option, but the installed drivers would remain.(I thought sys restore would remove a program/driver installed after restore point?)

With all the drivers "installed", and win7 booting 2 times in a row w/o problem, I tried some of the auto overclocking options with the Asus board. Everything I tried crippled windows, bsod, system restore boot screen, black screen etc. Even after disabling OC options windows would take 3-4 more boots to figure it out.
(With the Auto OC options the system would start and restart up to 3-4 times, I assume that's the mobo testing settings to find the sweet/stable spot - wish I knew more about the conditions it's checking...)
One of the stop messages I recorded during an OC attempt was (I saw this STOP many times, just didn't take good notes)
STOP 0xF4 (0x03,0xFFFFFA801......,0xFFFFFA801.......,0xFFFFF8000.......) (Don't expect address and exception parameters to be useful to anyone)

That being said here's what I saw when windows was "stable" before OC.
- Boot times were 20s-2min, not what I wanted from an SSD. (Sometimes succeeded, sometimes failed to load win)
- Marvell utility eventlog never showed a single problem report.
- The Marvell GUI is pretty short on options, the CLI offers much more info.
- Windows never recognized the 2nd WD HDD, but the Intel Storage Utility running within windows sees it fine. Bios recognizes it too.
- HDTune default test on the Marvell VD shows 280+Mb/s but only for 5seconds (and always 5s +/- 0.5sec), then it falls to 100-110, the same speeds if I test the extra WD HDD (which it recognizes). I suspect this is at least partly due to the HDTune program reading/writing in a way the Marvell algorithm isn't optimized for.
- Bios was updated to 1204
- Memory is set to auto in bios and ends up running at like 9-9-9 1333Hz (its listed at 1600, 7-8-7-24) If I change Auto to XMP, windows won't start - also tried leaving on auto and changing freq to 1600, crashed windows. Next time I will try to set the timing to 787 manually.
- Running win7 memory diagnostic tool right now, with extended tests - been stuck on pass 1 of 2: 21%, overall status 10% for at least an hour. Memory is cool to touch (yes to static wrist strap) - Google suggests extended tests can last overnight - anyone back this up?
- The Asus QVL doesn't list either the SSD or the RAM I have so that could be an issue - (Newegg sold out of the approved SSD while I was checking out.)
- On cold boot, bios reports chip at ~40C, AI Suite in OS reports chip at 26-30C.
- Have a CoolerMaster 212+, Arctic Silver5 in push(up from below) packed in Antec 900 MidAtx case, all fans on high.
- Heard things about C3/C6 reports from bios (to OS?), Disabled at some point, may have helped but didn't solve OC crashes.

So, since I have found so little information out there about setting up HyperDuo I figured I would post my experience so far - not trying to hijack the thread. Would be great to hear from someone successfully running Hyp with what componenets instead of all the marketing garbage that I've seen so far. I am not an experienced system builder or overclocker so I would be happy if someone tells me memory timings need to be set or something simple - please point out things I've overlooked or tests to try.


If anyone knows of a forum discussing HyperDuo please post, I have yet to find anyone but Marvell's marketing department sharing info!

thanks



lmlim said:
Hello,



Has anyone tried hyperduo function on this mobo yet? mind sharing some info a bit? speed? problems? etc?
I am planing to move my ssd n 1 of my raid hdd to Hyperduo. need some advice first...

thanks...
martin

m
0
l
February 15, 2011 2:12:46 AM

I've had hyperduo running for a couple of weeks now with no issues thankfully. I paired a Hitachi 2GB deskstar HD with corsair force 120 SSD. That SSD isn't on the qualified list either but it has worked fine.

You need to have the SSD on the top Marvell port and the HD on the bottom port. There is a thread here which has some good information for settting it up http://vip.asus.com/forum/view.aspx?SLanguage=en-us&id=...

Rest of my specs are Asus p6 Deluxe, 8GB G.skill cl9d-8gbrl DDR3, Nvidia GTx 570, 2600K, Silverstone Modular 750W, win 7 Pro 64-bit. Overclocks to 4600 without any issues either.

I quite like Hyperduo. It's definitely not as fast as having an SSD and a HD seperately but for the extra flexibility I think it's a good compromise.
m
0
l
April 29, 2011 6:08:10 PM

Faking,

Have you ever tried hibernating or hybrid sleep with your configuration?

My config is very similar and fails to sleep when hybrid sleep is enabled (fully powers down instead and Windows complains about improper shutdown upon restart). With hybrid sleep disabled, I'm able to sleep and awaken just fine, but hibernation does not work: upon wakeup, Windows also complains about improper shutdown and performs a full boot. I'm thinking the Marvell driver does not properly flush buffers before hibernation, but I'm not sure why hybrid sleep would not at least leave the live boot in RAM functional. Asus suggests an RMA on the motherboard, but I'd hate to swap hardware if its a driver issue.

The issue is also there without hyperduo, booting from the SSD, but goes away if I use the Intel 6GB/s SATA ports instead of the Marvell.

My config: p8P67 DLX, hyperduo (Crucial C300 64 GB SSD, WD Caviar Black 1.5 TB HDD), Gigabyte GTX 560 Ti, no overclocking.
m
0
l
!