Sign in with
Sign up | Sign in
Your question

Bad Motherboard? System Just shut off and now no Power.

Last response: in Motherboards
Share
February 7, 2011 1:54:34 AM

Hi, I have a frankenstein pc housed in an old emachines tower that I pieced together recently. I had the build up and running for a day or so when I went to go type something and press enter and bam it shut right off. Surely a coincidence that it powered off as soon as I hit enter but now it won't turn on. There was no burning smell or other noticable oder after it happened even after opening the case.

NowThe power supply is good as ive tested all 3 I have on known working machines and they are all good. Ram is good and I'm sure cpu is. Im getting no beeps from mb but I don't have a speaker hooked up to it. I tried using a speaker from another pc and still no beeps. When I go to power it on all the fans turn about a half inch immediately then die out. Sure sounds like a bad mb to me. I bought it off newegg about a year ago and have never had the time to use it till now. Can anybody help me with this? Any help would be appreciated. Here are the specs on it.

Biostar 945GZ Socket775 Motherboard
Intel Core2 Duo. I think it's a 5400
1gb Corsair DDR2 XMS2 Ram.

I have also tried unplugging all unnecessary components with no luck
a c 1026 V Motherboard
February 7, 2011 9:08:53 PM

If the PSU is working then it most likely is the motherboard.
a c 197 V Motherboard
February 8, 2011 3:47:02 PM

rolli59 said:
If the PSU is working then it most likely is the motherboard.

+1to rolli59. To quote the great Leonard "Bones" McCoy, "she's dead, Jim".......
February 8, 2011 3:49:36 PM

It may not be the MB. It could be the VGA card if you have one. Had the samething happen to me twice in the last 5 years. Just pulled the VGA card and my system powered up. So I knew that the VGA card was toast.
!